1. nvsdesign
  2. RO Payments
  3. Wednesday, 28 December 2022
  4.  Subscribe via email
Hi Roland,

I'm having an issue with RO Payments giving me the following error:


RO Payments kan het notificatie script niet openen. Het notificatie script is vereist om de terugkoppeling van de betaalprovider te verwerken. U zult toegang tot dit script moeten instellen, controleer hiervoor de firewall, htaccess of andere instellingen die de toegang verhinderen. Het notificatie script is te bereiken op https://xxx.nl/cli/notify.php.

Het antwoord ontvangen van de server:
Status code: 403
Bericht: Forbidden.


I've disabled Admin Tools and my custom htaccess (created with Admin Tools) but the error keeps on showing. When I go to this url I see a white page with NOK on it, so the script is reachable.

Do you have any other ideas how to solve this?

Regards, Niels
Accepted Answer Pending Moderation
Hello Niels,

When I go to this url I see a white page with NOK on it, so the script is reachable.
You are testing this from your computer. The check RO Payments is doing is going from server to server. Is there something on the server preventing the server from calling itself?
Kind regards,

RolandD

=========================
If you use our extensions, please post a rating and a review at the Joomla! Extension Directory
  1. more than a month ago
  2. RO Payments
  3. # 1
Accepted Answer Pending Moderation
Is there something on the server preventing the server from calling itself?


Not that I know of. It always worked correct, but stopped working when I updated the website to Joomla 4 today. In the old J3 website this notification didn't occur.
  1. more than a month ago
  2. RO Payments
  3. # 2
Accepted Answer Pending Moderation
Hello Niels,

The notification check is the same in J3 and J4. There must be something blocking it on your server, we have no other users with this issue. I checked our demo site and there is no such issue either. Perhaps the hosting company can tell you what is blocking the request.
Kind regards,

RolandD

=========================
If you use our extensions, please post a rating and a review at the Joomla! Extension Directory
  1. more than a month ago
  2. RO Payments
  3. # 3
Accepted Answer Pending Moderation
Hi Roland,

I've did some more research for this issue. The hosting company points to the (Admin tools) htaccess file, but the configuration doesn't lead to any issues on other servers. Also when we use the Joomla default htaccess the error persists.

I've discovered that the webserver is using LiteSpeed, could that cause the issue? We don't have any problems on several Apache servers. While I think of it, the J3 version of this website does work with RO Payments on the LiteSpees server. Maybe something has changed between both Joomla versions?

Regards, Niels
  1. 2 weeks ago
  2. RO Payments
  3. # 4
Accepted Answer Pending Moderation
Hello Niels,

I have no experience with LiteSpeed so I cannot speak for that. As for a change in Joomla, yes, a lot has changed between Joomla 3 and Joomla 4. It is from one major version to another major version. However I have not heard from other customers running Joomla 4 that they have this issue.

Regardless of server or software version, is there no logging of what is being blocked?
Kind regards,

RolandD

=========================
If you use our extensions, please post a rating and a review at the Joomla! Extension Directory
  1. 2 weeks ago
  2. RO Payments
  3. # 5
  • Page :
  • 1


There are no replies made for this post yet.
Be one of the first to reply to this post!