1. DaPowerrr
  2. RO Payments
  3. Friday, 04 September 2020
  4.  Subscribe via email
Help!

Working with latest joomla (3.9.21) and RSEvents (1.13.1) ROPayments (6.0.2) and Rabo omnikassa .

Last couple of days payments with iDeal work 8 out of 10 times. We now have a new problem showing up that people can chose the tickets and proceed to cart but as they click on payment they get back to the original list of events, instead of to the iDeal payment page.

Shown message on the cart page is : "Notice: Undefined index: task in /home/public/sites/http://www.pvpaspartoe.nl/components/com_jdidealgateway/router.php on line 72"

What does this mean and how do I solve this. (Sorry if it's again a newbe question..)

As I said, 8 out of 10 times there's no problem with the transactions... There are only a few members who experience these problems.

Can you please help?
Accepted Answer
Accepted Answer Pending Moderation
Wellllll....
I tried to check the logs, but apart from some missing id I couldn't find really crazy things.

And then I set the protostar template to standard on all pages, tried the payment again and saw where the problem was. (for about 1 second because then he indeed went back to complete eventlist..)

It's not in the iDeal button or the connection between site and iDeal, not in RSEvents itself but in the cart (or winkelwagen) plugin from RSjoomla.

Because he takes info from the sitesubscription and states them mandatory, if a member doesn't have that info filled in, it firstly stalls and then he reroutes himself to the eventlist. I tried by manually filling in empty fields and I directly got the possibility to pay with iDeal.

i am so sorry to have bothered you with a problem that wasn't even with your extension!

And so many kudo's and thanks to you for helping me for the directions I needed to look!



(I am gonna remember that protostar thing now ;) )
Accepted Answer Pending Moderation
Hello,

What does this mean and how do I solve this. (Sorry if it's again a newbe question..)
The message is what it says, just a notice to inform you of something that is not totally correct. This is nothing serious. However what I don't understand is how you can see this notice because you should not get into that path. This means you are using the Payment Form of RO Payments and not RSEvents.

Do you have any menu items setup for the RO Payments payment form? If yes, please check them and resave them. It is good practice to turn off error reporting on a live site as you don't want to expose any site details to the public.

but as they click on payment they get back to the original list of events
This has the indication of a different issue. Please check the payment log on the Transactions page and see if you find anything there. If there is nothing obvious for you, post the transaction log here and I can take a look.

There are only a few members who experience these problems.
This tells me there is something specific about those circumstances and not a general issue. Let's see what we can find.
Kind regards,

RolandD

=========================
If you use our extensions, please post a rating and a review at the Joomla! Extension Directory
  1. 3 weeks ago
  2. RO Payments
  3. # 1
Accepted Answer Pending Moderation
Roland,

I was the only one getting the message on checkout page for a test transaction I enabled the max-errorreporting and got that error. Immediately afterwards I disabled it frontend.

I dont exactly understand what you need and which transaction log. If I open the latest unsuccesful transaction-log i see:
[2020-09-03 11:13:57] Gekozen kaart(en):

[2020-09-03 11:13:57] Currency: EUR

[2020-09-03 11:13:57] Set transaction details

[2020-09-03 11:13:58] Send customer to URL: https://betalen.rabobank.nl/omnikassa/nl/payment-brand?token=eyJraWQiOiJFTU8iLCJhbGciOiJFUzI1NiJ9.eyJlbW8iOiI4NmNkNTAwMi0zNDFhLTQ3NTItYTUyMi1jNzlkMmNkYzNhZjUiLCJjaWQiOiJiYjMxLWFjMmIiLCJleHAiOjE1OTkxMzcwMzd9.KI0L-ptXvfl7nxuz2Z1CSUzjKjyp7zznZV-eKjLCo8L2a15NJB0m4FlwKQHvoooMm6Pwc96saATTGxvpdcmfbA


As you can see in the attached picture it's a show of yes and no. And to me it's not clear where the problem may occur.

If you need more info please let me know.
Things haven't run smoothly with us with iDeal. Well, sometimes it does and sometimes it doesn't. I would like to have it operate corectly.

Thanks for helping me along!
Attachments (1)
  1. 3 weeks ago
  2. RO Payments
  3. # 2
Accepted Answer Pending Moderation
Hello,

Here is what I am thinking. In the case where you are returned to the list of events, there is an error of some kind but your template doesn't have the message box and as such no message is shown.

I dont exactly understand what you need and which transaction log
that is why I wrote Please check the payment log on the Transactions page. This is in the RO Payments component, but you found it. :)

[2020-09-03 11:13:58] Send customer to URL: https://betalen.rabobank.nl/omnikassa/nl/payment-brand?token=eyJraWQiOiJFTU8iLCJhbGciOiJFUzI1NiJ9.eyJlbW8iOiI4NmNkNTAwMi0zNDFhLTQ3NTItYTUyMi1jNzlkMmNkYzNhZjUiLCJjaWQiOiJiYjMxLWFjMmIiLCJleHAiOjE1OTkxMzcwMzd9.KI0L-ptXvfl7nxuz2Z1CSUzjKjyp7zznZV-eKjLCo8L2a15NJB0m4FlwKQHvoooMm6Pwc96saATTGxvpdcmfbA
This part in the log looks good and you should be forwarded to the Rabobank. The only thing RO Payments does at this point tell Joomla to send you to this URL and control is back to Joomla.

What goes wrong when Joomla takes over there is no way of telling that from the point of view of RO Payments. If your user account always has this issue, perhaps you can test it on your test site using the Protostar template, this definitely has the message box.

Perhaps needless to say but I cannot reproduce this behavior and it seems to be some kind of set of circumstances on your site that prevents the redirect. Are you using Admin Tools or something similar as firewall? Perhaps you need to whitelist RO Payments.
Kind regards,

RolandD

=========================
If you use our extensions, please post a rating and a review at the Joomla! Extension Directory
  1. 3 weeks ago
  2. RO Payments
  3. # 3
Accepted Answer Pending Moderation
Thanks again for your response!

We used to have admin tools on this site, but after earlier problems we completely redid the site and new database without a new install of AT.

We are actually kind of basic on this site, but experience the most problems (not blaming anyone for that!)

The log I copied was the complete log. Normally the log is a lot bigger with a lot more info including transaction details and results.

I will try your suggestion to test on separate template. Normally though I get the message on screen when there is a message to be shown, like with mistakes or problems on submissions or even not so long ago with the omnikassa refresh token problem (which has been solved now afaik)


Will be back!
  1. 2 weeks ago
  2. RO Payments
  3. # 4
Accepted Answer Pending Moderation
Hello,

The log I copied was the complete log.
Yes I understand that, this also tells us that something is stopping the redirect to the Rabobank within your site. What is strange that it doesn't always happen. You can check your logs folder for the log files there, perhaps there is something in there as well.
Kind regards,

RolandD

=========================
If you use our extensions, please post a rating and a review at the Joomla! Extension Directory
  1. 2 weeks ago
  2. RO Payments
  3. # 5
Accepted Answer Pending Moderation
Hello,

I am glad you figured out what the problem is and for informing us.
Kind regards,

RolandD

=========================
If you use our extensions, please post a rating and a review at the Joomla! Extension Directory
  1. 2 weeks ago
  2. RO Payments
  3. # 6
  • Page :
  • 1


There are no replies made for this post yet.
Be one of the first to reply to this post!