1. woluweb
  2. RO Payments
  3. Sunday, 28 February 2021
  4.  Subscribe via email
Hi Roland!
I hope you are fine.

A couple of months ago, with the help of Anja D. we have setup a donation form, using RS Forms Pro coupled with RO Payments.

Now it is about to go in production, but I realize that I had a little issue : the emails (to user and to admin) were sent immediately when the RS Form was submitted, indepentently of the payment (and its success).

So I was happy to see that you have foreseen this with the "Defer user email" and "Defer admin email" Options:

https://rolandd.com/documentation/ro-payments/rsform-pro-form-settings-for-ro-payments

But when I set these to YES then no email is sent at all (when it is set on NO then the emails are sent normally)

How comes ?
Have I missed something ? (Is this Option dependent on some other Option, like on the RO Payment Profile or... ?)
Accepted Answer Pending Moderation
maybe it can help:

In the backend, RO Payment says

The answer received from the server is:
Status code: 403
Message:
Forbidden
You don't have permission to access this resource.


Still,
/cli/notify.php
does not give a 403 in the front-end when called from the browser
It simply says "NOK"
(no 403 anyway)
  1. more than a month ago
  2. RO Payments
  3. # 1
Accepted Answer Pending Moderation
Note: I forgot to mention, but I also looked at
https://rolandd.com/documentation/ro-payments/i-receive-a-403-page-after-payment

And I have the same error msg even when I totally disable Admin Tools.
The .htaccess at the root is the Joomla's basic one
And the first thing I did was to remove an .htaccess which was in the /cli folder, so there is no other .htaccess who could annoy us here.
  1. more than a month ago
  2. RO Payments
  3. # 2
Accepted Answer Pending Moderation
I have tested the "defer email" feature on another website that I am building (for the rock band of my daughter :) ).
(link in the Site details hereafter)

And there
* the backend of RO Payments does not show any 403 error
* and the "defer email" seems to work fine
* even if calling /cli/notify.php in the browser also shows "NOK"

So I guess that the "NOK" is not a problem... but I still have no clue why RO Payment's backend shows that 403 error while the notify.php is accessible even from the browser.

Any clue ?
(sorry if I keep adding comments but hopefully it can help you to help me ;) )
  1. more than a month ago
  2. RO Payments
  3. # 3
Accepted Answer Pending Moderation
Hello Marc,

But when I set these to YES then no email is sent at all (when it is set on NO then the emails are sent normally)
This will happen if RO Payments does not receive a success status on the payment OR if you have the RSForm Payment package active.

If you see NOK on the /cli/notify.php that is fine because it just means Not OK and that happens because you are not sending a valid request to the script. Sometimes the server does not allow to call itself and you see this error.

Please post the transaction log of the payment you tested. Let's see what that says.
Kind regards,

RolandD

=========================
If you use our extensions, please post a rating and a review at the Joomla! Extension Directory
  1. more than a month ago
  2. RO Payments
  3. # 4
Accepted Answer Pending Moderation
Hi Roland.
Hereafter you will find the transaction details (actually I see all the transactions (sucess, expired, ...) in RO Payments > Transactions.

And there is no other payment plugin than RO Payments (no RSForms payment for example).

Above all, I still see the red screen about the 403 error on RO Payments dashboard. See here : https://www.screenpresso.com/=esasg

Txs,

Marc

[2021-03-01 11:41:07] Selected card(s):

[2021-03-01 11:41:09] Set transaction details

[2021-03-01 11:41:09] Currency: EUR

[2021-03-01 11:41:09] Send customer to URL: https://www.mollie.com/payscreen/select-method/aMfNF8uF9W

[2021-03-01 11:41:14] Process directly

[2021-03-01 11:41:14] User agent: Mollie HTTP client/1.0

[2021-03-01 11:41:14] Query string: transaction_id=1614595269

[2021-03-01 11:41:14] Payment provider calling

[2021-03-01 11:41:14] Get transaction ID

[2021-03-01 11:41:14] Received transaction ID 1614595269

[2021-03-01 11:41:14] Get transaction status

[2021-03-01 11:41:14] id:tr_aMfNF8uF9W

[2021-03-01 11:41:14] transaction_id:1614595269

[2021-03-01 11:41:14] Received payment status: paid

[2021-03-01 11:41:14] Received card: bancontact

[2021-03-01 11:41:14] Set transaction details

[2021-03-01 11:41:14] Payment has SUCCESS status

[2021-03-01 11:41:14] Current order status P

[2021-03-01 11:41:14] Send customer change status email

[2021-03-01 11:41:14] {"order_number":"87","order_id":"3.87","order_total":"50.00000","order_status":"C","user_email":null,"order_comment":"Transaction number: 1614595269"}

[2021-03-01 11:41:14] Send admin order payment email

[2021-03-01 11:41:14] Notifying extension on URL: https://new.josefa-foundation.org/index.php?option=com_rsform&formId=3&task=plugin&plugin_task=jdideal.notify&Itemid=1047&lang=fr&transactionId=1614595269&pid=B8z05WO7uoHPIg0TezQxBqePp2eZ0uw6NaaB23pDLbHVLdhgli

[2021-03-01 11:41:14] Notify method: get

[2021-03-01 11:41:14] Received HTTP status 403

[2021-03-01 11:41:14] Process directly

[2021-03-01 11:41:14] User agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/88.0.4324.190 Safari/537.36

[2021-03-01 11:41:14] Query string: transaction_id=1614595269&output=customer

[2021-03-01 11:41:14] User admin-woluweb is calling.

[2021-03-01 11:41:14] Redirecting customer to: https://new.josefa-foundation.org/index.php?option=com_rsform&formId=3&task=plugin&plugin_task=jdideal.return&Itemid=1047&lang=fr&transactionId=1614595269&pid=B8z05WO7uoHPIg0TezQxBqePp2eZ0uw6NaaB23pDLbHVLdhgli

[2021-03-01 11:41:14] Redirect to https://new.josefa-foundation.org/fr/donate-month?hash=1bc77436f06e23874a79784b093cee0c
  1. more than a month ago
  2. RO Payments
  3. # 5
Accepted Answer Pending Moderation
Hello Marc,

[2021-03-01 11:41:14] Received HTTP status 403
You can see this in the log and that is the same as you see in the backend. This means there is still something on your server blocking the request. In turn this means that is why you are not getting the emails because the update call fails.

The reason for this is that you have the site set to offline. So nobody can access the site without login. Set the site online and you can test your payments.
Kind regards,

RolandD

=========================
If you use our extensions, please post a rating and a review at the Joomla! Extension Directory
  1. more than a month ago
  2. RO Payments
  3. # 6
Accepted Answer Pending Moderation
Txs Roland.
I have set the website "online" (not "offline" any more).

But RO Payments still shows the red "403 forbidden"...

I have also completely disabled all the stuff from Admin Tools, just to make things easier. But same result...

(I have also temporarily renamed .htaccess at the root into XXX.htaccess, but I still see the red "403 forbidden";)

Any other clue?

Note: just FYI the website is hosted at OVH. And the ".ovhconfig" says the following :
app.engine.version=7.3
http.firewall=none
environment=development
container.image=stable

(so even there the firewall is set to "none";)
  1. more than a month ago
  2. RO Payments
  3. # 7
Accepted Answer Pending Moderation
Hello Marc,

Looking at your site I think it is something server level that is blocking it because when I open the notify URL in the browser it works fine. However when I use cURL (that is what RO Payments uses because it is not a browser), I get the 403, see this response:

$ curl -I https://new.josefa-foundation.org/cli/notify.php
HTTP/2 403
date: Tue, 02 Mar 2021 07:33:03 GMT
content-type: text/html; charset=iso-8859-1
server: Apache
x-content-type-options: nosniff
The same is even when I access the homepage

$ curl -I https://new.josefa-foundation.org/
HTTP/2 403
date: Tue, 02 Mar 2021 07:34:06 GMT
content-type: text/html; charset=iso-8859-1
server: Apache
x-content-type-options: nosniff
Check with your hosting provider if they are blocking this on a server level. The mod_security comes to mind what they may have in use.
Kind regards,

RolandD

=========================
If you use our extensions, please post a rating and a review at the Joomla! Extension Directory
  1. more than a month ago
  2. RO Payments
  3. # 8
Accepted Answer Pending Moderation
Txs Roland for the quick follow-up.

I check with the hosting Cy (I hate OVH :D )
  1. more than a month ago
  2. RO Payments
  3. # 9
Accepted Answer Pending Moderation
Hi Roland,

I wanted to get back to you bc I think the issue of that "Status code: 403" with OVH is solved.

Actually I had contacted their support... but it was useless (as usual with them) bc they simply said that there was nothing wrong with their servers and that they were not blocking anything.

I had already warned the customer that the easiest workaround would be to change the Hosting Company :D
But then, almost by by chance I discovered the real reason for this when I put the website into production.

Bc then I had two url :
https://new.DOMAIN.org/ the development website, where there was the issue
https://www.DOMAIN.org/ the production website, where the issue was gone ! (even if it was the same website in the same directory, not even a duplicate)

In fact the only difference is that "firewall" option.
By default it is always ENABLED.
But by chance, on the (very old) website if was set on DISABLED. And then visibly the 403 error is gone :)

So I wanted to share with you bc you might have other customers one day with the same issue...
That setting can be changed in the interface but actually it only reflects the ".ovhconfig" file (more info on https://docs.ovh.com/gb/en/hosting/configuring-file-ovhconfig/ )

More specifically this section of .ovhconfig :


; __http.firewall__ used to add application firewall (filter http requests)
http.firewall=none


Txs again Roland for your previous answers (and for your commitment to the Joomla project :) )
Attachments (1)
  1. one week ago
  2. RO Payments
  3. # 10
Accepted Answer Pending Moderation
Hello Marc,

Thank you for your feedback on this. This is quite important to know and unfortunately the helpdesk doesn't really help although you would think they know about these things :D

Certainly something to keep in mind and I will see if I can incorporate it in the documentation.

Thank you as well for your presentations :)
Kind regards,

RolandD

=========================
If you use our extensions, please post a rating and a review at the Joomla! Extension Directory
  1. one week ago
  2. RO Payments
  3. # 11
  • Page :
  • 1


There are no replies made for this post yet.
Be one of the first to reply to this post!