1. Donnerflug
  2. RO CSVI
  3. Wednesday, 04 January 2017
  4.  Subscribe via email
Hello Tharuna,

made the update in a test environment to CSVI 7.0 and all menu links AND all installed third party components like JCE, VMUIKIT, Yootheme widgetkit exept Virtuemart are gone or perhaps invisible.

You can try it with shop.winzersekt.de.

Kind regards,

Teresa
Accepted Answer Pending Moderation
Hello Tharuna,

restored the Joomla menu table from backup of the 6.6.4 installation and all links are visible again.

However wether export nor import works on front-end in V7

Kind regards,

Teresa
  1. more than a month ago
  2. RO CSVI
  3. # 1
Accepted Answer Pending Moderation
Hello Teresa,
I was looking into your shop.winzersekt.de. site and yes after CSVI 7 update saw few menu links disappearing. However i looked into your backup database wo_shop_demo_backup to compare it with wo_shop_demo and found an issue with path column for VMUIKIT component(an example) in #__menu table. You can see that it has been stored with com-csvi-about in path. This issue has been fixed in CSVI sometime back and Roland has explained the cause for this issue in this thread. I would suggest you to fix this problem first and then try updating to CSVI 7.

However wether export nor import works on front-end in V7

Lets fix your menu link problem and i will look into this on your site when you have CSVI 7 up and running.
Kind regards,

Tharuna

=========================
If you use CSVI, please post a rating and a review at the Joomla! Extension Directory
  1. more than a month ago
  2. RO CSVI
  3. # 2
Accepted Answer Pending Moderation
Hello Teresa,
In CSVI 6.6.4 you may see an error when using Fix menu button in CSVI About page. Please load the patch file in the post here and it should be good.
Kind regards,

Tharuna

=========================
If you use CSVI, please post a rating and a review at the Joomla! Extension Directory
  1. more than a month ago
  2. RO CSVI
  3. # 3
Accepted Answer Pending Moderation
Hello Tharuna,

both patch files didn't solve the menu issue. Modified the menu table manually and installed the V7 successfully.

Please let's try to solve the import/eport issue

Kind regards,

Teresa

PS: When creating a new link, the both vnuikit links are still in under the menu type of CSVI. How can I remove them?
  1. more than a month ago
  2. RO CSVI
  3. # 4
Accepted Answer Pending Moderation
Hello Teresa,
May i know the issue you have front end import/export? I tried to do category export in front end of shop.winzersekt.de and see the export working. Please provide more details on what is not working.
Kind regards,

Tharuna

=========================
If you use CSVI, please post a rating and a review at the Joomla! Extension Directory
  1. more than a month ago
  2. RO CSVI
  3. # 5
Accepted Answer Pending Moderation
Hello Tharuna,
did you modify anything? I swear, that wether import nor export is working. I had errors like no file or no template.

Import doesn't work without specifying a file on the server! Is there any way to load a file from computer for Import?

Thank you!

Teresa
  1. more than a month ago
  2. RO CSVI
  3. # 6
Accepted Answer Pending Moderation
Hello Teresa,

Best wishes for 2017 to you.

If you want to import a file located on your computer you need to modify the template and set on the Source tab the Load from your computer. During import CSVI will ask you for the file, which you can then upload.
  1. more than a month ago
  2. RO CSVI
  3. # 7
Accepted Answer Pending Moderation
Hello Teresa,
Just to clarify, if you are trying to set Load from your computer for your front end import then it wont work, front end import supports only file from server option.
Kind regards,

Tharuna

=========================
If you use CSVI, please post a rating and a review at the Joomla! Extension Directory
  1. more than a month ago
  2. RO CSVI
  3. # 8
Accepted Answer Pending Moderation
Morning Tharuna,

Yes, I've noticed that. May I ask in this context: Why do you offer these options at this position if they do not work anyway?

This only leads to unnecessary irritations and the corresponding waste of time. A small note in the help would be sufficient.

Nevertheless thanks for the help!

Kind regards,

Teresa
  1. more than a month ago
  2. RO CSVI
  3. # 9
Accepted Answer Pending Moderation
Morning Teresa,
Why do you offer these options at this position if they do not work anyway?

All the options given in source tab are for backend import and export and they work good on backend. Front end import/export is very limited. To be very clear front end import and export trigger the backend import and export as there is no separate code or process for front end.

This only leads to unnecessary irritations and the corresponding waste of time. A small note in the help would be sufficient.

Yes will add this in the help text in the backend. Thank you for the feedback.
Kind regards,

Tharuna

=========================
If you use CSVI, please post a rating and a review at the Joomla! Extension Directory
  1. more than a month ago
  2. RO CSVI
  3. # 10
Accepted Answer Pending Moderation
Hello Teresa,

Thank you for your suggestion. The reason why these options are there is because some users can't run cron jobs on their servers and want to trigger the import from the front-end via a URL. As per your suggestion I will update the help text.
  1. more than a month ago
  2. RO CSVI
  3. # 11
Accepted Answer Pending Moderation
Hello Tharuna,

I'm really fed up! I can not believe it! Absolutely nothing works properly with import/export on front-end!

I made a clean install of CSVI 7 and restored my templates. Here I noticed that the rules are imported several times!?!?

Tested it with the templates "Kategorie EXPORT NEU" and "Kategorie IMPORT NEU"

1. Front-end EXPORT via "Download" works!
2. EXPORT via "Save on server" and "Save on FTP server" ends in a blanc screen AND files are not saved on server.
3. Import via "Load from server" ends in an error: COM_CSVI_LOCAL_FILE_IS_NOT_FILE

Front-end links:
http://weine-sekt.de/index.php/shopabgleich

Click on "Kategorien exportieren" and/or "Kategorien importieren"

You need to login in front-end as Joomla Amin "sauflui"

Kind regards,

Teresa

I've sent you PM with access data
  1. more than a month ago
  2. RO CSVI
  3. # 12
Accepted Answer Pending Moderation
Hello Teresa,
I made a clean install of CSVI 7 and restored my templates. Here I noticed that the rules are imported several times!?!?

If the rules has been shared between templates while restoring templates each rule associated with the template gets restored individually. This could be a reason you are seeing duplicates.

2. EXPORT via "Save on server" and "Save on FTP server" ends in a blanc screen AND files are not saved on server.

There was an issue with export on front end on CSVI 7. Its fixed on your site. You can see the export working now.

3. Import via "Load from server" ends in an error: COM_CSVI_LOCAL_FILE_IS_NOT_FILE

The actual text is that your import file is not readable. Since the language strings are not translated you were not able to find the cause. You can see the error now on your front-end import.
Kind regards,

Tharuna

=========================
If you use CSVI, please post a rating and a review at the Joomla! Extension Directory
  1. more than a month ago
  2. RO CSVI
  3. # 13
Accepted Answer Pending Moderation
Hello Tharuna,

thank you!

1. Still a problem with front-end exports. Processing any export ends in a blanc page. However files are saved on the server.
2. Triggering "Product Export" and "Product Id Export" ends in an empty(no data) file when processing from Backend AND Front-end.

Kind regards,

Teresa
  1. more than a month ago
  2. RO CSVI
  3. # 14
Accepted Answer Pending Moderation
Hello Teresa,

I am going to have a look at this. The empty export of the Product Export and Product Id Export has been fixed. The reason for this is that when no value has been set for quantities the value of 0 comes back. This was not a problem before but we allowed the export of products where stock is 0, so this caused the export to filter on products where quantity is 0. I have made a change so your export works and will include this in in the next release.

As for the front-end export, these are set to use the template but the template doesn't have a Screen option. This causes the export to only export to the destinations set in the template. As a quick fix, I have set that all templates also export to Screen, so they will display some output. I am going to see how we can make this a more permanent feature.

Let me know if there is anything else you would like me to take a look at.

Thank you for your patience.
  1. more than a month ago
  2. RO CSVI
  3. # 15
Accepted Answer Pending Moderation
Hello Roland,

meanwhile I reach my limits - short before kicking off this fu.. project! I'm crazy to spent so much time and money and no end in sight!

Played around with Front-End and get different issues. Some output comes on screen, other is blanc, next doesn't save the file on server ......................................................................................................................... .......................................................................................................................... .......................................................................................................................... .........................................................................!!!!!

Every new step opens 5 more issues!

Regards,

Teresa
  1. more than a month ago
  2. RO CSVI
  3. # 16
Accepted Answer Pending Moderation
Hello Teresa,

So I had a look at all your export templates, they all output data. The shopabgleich/export-artikelpreise page shows a blank page but there is actually data, just the browser doesn't show it. You can see the actual data by pressing CTRL-U/CMD-U to see the source of the page.

The /shopabgleich/export-bestellungen page gives no output because there are no new orders since it last ran.

All exports also write the file to the server, at least I see them showing up after running the template.

Let me know if I missed anything, I will be happy to check it for you.
  1. more than a month ago
  2. RO CSVI
  3. # 17
Accepted Answer Pending Moderation
Hello Roland,

thank you, it seems to work in front ent.

However, the output for exports on screen is unprofitable.

Would you be so kind to modify the export output to download as well as to save on local and FTP servers?

Kind regards,

Teresa
  1. more than a month ago
  2. RO CSVI
  3. # 18
Accepted Answer Pending Moderation
Hello Teresa,
I fixed all your exports to download, save on server and save on ftp options. Download and Save on server works but couldn't test Save on FTP option as i don't have credentials to check the file on FTP. Can you check all of your exports on front end and let me know? If you have any issue on Save on FTP can you send me the details saved in EXPORT Kategorien template to test?
Kind regards,

Tharuna

=========================
If you use CSVI, please post a rating and a review at the Joomla! Extension Directory
  1. more than a month ago
  2. RO CSVI
  3. # 19
Accepted Answer Pending Moderation
Hello Tharuna,

it seems to work now! Thanks again!

Due to moving to live site, please tell me all files which you and Roland modified in this thread. Or when may I expect an update?

Kind regards,

Teresa
  1. more than a month ago
  2. RO CSVI
  3. # 20
  • Page :
  • 1
  • 2


There are no replies made for this post yet.
Be one of the first to reply to this post!