1. cyberspyder
  2. RO CSVI
  3. Monday, 12 July 2021
  4.  Subscribe via email
I can't figure out why these files will not fully process. There are only 3 lines, so I don't think it's timing out. It only does the first and last line. It is like it doesn't even see the second line. I thought maybe something was malformed, but I removed the first and last line and the missing product was added fine. I tried moving the order around after adding all 3 back in. No matter what order the lines are in, it does whatever the first one and last one are, and skips the middle one. I tried 3 different online validators for XML and it's clean and well formed every time. I tried reading the logs to see where the error happens, and it just isn't recognizing the line. I don't see any errors anywhere. I just can't figure this out, can you please take a look at it? I have attached the log, the template backup and the file I'm trying to import.
Attachments (1)
Accepted Answer Pending Moderation
Hello,
I was able to see that second product is not recognised from your file with RO CSVI 7.20.0 version. In this version we introduced new XML parser and could possibly be the reason for the conflict of not reading one product from XML file. We have done a lot of improvements to XML parser and testing with the new code does read the second product from your import file. These changes are included in our upcoming release which is expected to be coming soon. I can share the latest RO CSVI package if you can share the email ID to send the package.
Kind regards,

Tharuna

=========================
If you use CSVI, please post a rating and a review at the Joomla! Extension Directory
  1. 3 weeks ago
  2. RO CSVI
  3. # 1
Accepted Answer Pending Moderation
Thank you very much! steph@cyberspyder.net
  1. 3 weeks ago
  2. RO CSVI
  3. # 2
Accepted Answer Pending Moderation
Hello,
Thank you for sending the email ID. Instead of the whole package, i am attaching patch file with new XML code. Please load the attached patch file from RO CSVI Maintenance page and run the import. Check if the patch fixes the import issue.
Attachments (1)
Kind regards,

Tharuna

=========================
If you use CSVI, please post a rating and a review at the Joomla! Extension Directory
  1. 3 weeks ago
  2. RO CSVI
  3. # 3
  • Page :
  • 1


There are no replies made for this post yet.
Be one of the first to reply to this post!