1. athenacraftsltdltd
  2. RO CSVI
  3. Thursday, 16 November 2017
  4.  Subscribe via email
First of all: Joomla 3.7.4, Virtuemart 3.2.2, CSVI Pro 7.2.3

Hi all, this is a rather odd problem.

I've spent some time trying to get my head around multivariants and studying the tutorial on here and I eventually got it working consistently - the parent product had two dropdowns for the variant options (size and quantity) and selecting a given combination selected the relevant child product and allowed them to be added to the cart - following a product import. I could repeatedly empty the VM database and reimport my file and get the desired results.

After this, I tried a product images import. As soon as this completed, the dropdowns vanished from the product. I have since tried emptying the VM database and reimporting the product import but to no avail - the dropdowns are simply not visible. I know the child products still exist on the site because I can browse to them by following the link in the product title in the back end.

To test, I asked our hosts to roll the site back to a backup taken yesterday afternoon where the dropdowns were still present and did this again and the same happened.
Please let me know what I need to do to get my dropdowns back.

Additionally, the only reason I attempted to import a product image import is because the parent product thumbnail didn't seem to apply when imported via the product import. The image was visible in the product details screen, but there was no image for the product on the category screen.
Accepted Answer Pending Moderation
Hello,
To check on the issue you need to send us your sample import file and the import debug log. To know on how to get the debug log check Where to get debug information? document.
Kind regards,

Tharuna

=========================
If you use CSVI, please post a rating and a review at the Joomla! Extension Directory
  1. more than a month ago
  2. RO CSVI
  3. # 1
Accepted Answer Pending Moderation
Hi Tharuna,

Sorry for the delay; I've been out of the office. I also can't run this immediately as it will break the website so I'll need to make sure that we have an up to date backup first. I'll post back later. Thanks.
  1. more than a month ago
  2. RO CSVI
  3. # 2
Accepted Answer Pending Moderation
Hi Tharuna,

I have an import file and a log. Is there somewhere I can send it? I'd prefer not to make it publicly available on the forum if that's at all possible.

Cheers,
Ian
  1. more than a month ago
  2. RO CSVI
  3. # 3
Accepted Answer Pending Moderation
Hello Ian,
You can send them as an email to tharuna@csvimproved.com.
Kind regards,

Tharuna

=========================
If you use CSVI, please post a rating and a review at the Joomla! Extension Directory
  1. more than a month ago
  2. RO CSVI
  3. # 4
Accepted Answer Pending Moderation
Hi Tharuna,

Just checking you got my files yesterday?
  1. more than a month ago
  2. RO CSVI
  3. # 5
Accepted Answer Pending Moderation
Hello,
No i did not receive your files. Can you try sending it again?
Kind regards,

Tharuna

=========================
If you use CSVI, please post a rating and a review at the Joomla! Extension Directory
  1. more than a month ago
  2. RO CSVI
  3. # 6
Accepted Answer Pending Moderation
re-sent
  1. more than a month ago
  2. RO CSVI
  3. # 7
Accepted Answer Pending Moderation
Hello,
Received you files. Will check and let you know on the findings.
Kind regards,

Tharuna

=========================
If you use CSVI, please post a rating and a review at the Joomla! Extension Directory
  1. more than a month ago
  2. RO CSVI
  3. # 8
Accepted Answer Pending Moderation
Hello,
Looking at your debug log the params for multi variants are stored empty and so you are not seeing the drop down boxes on front end. Do you have Size and Quantity custom fields already created in VirtueMart? If yes, try updating your available fields and then run the import. Check if your issue solves after that.
Kind regards,

Tharuna

=========================
If you use CSVI, please post a rating and a review at the Joomla! Extension Directory
  1. more than a month ago
  2. RO CSVI
  3. # 9
Accepted Answer Pending Moderation
Hi Tharuna,

Thanks for your response, and apologies for the delay in mine. I'll try what you've suggested this afternoon, but it raises a concern: I want to be able to automate the import of these files. I can do that with cron jobs and shell scripts, but if I have to log into the site every time we try to update it to manually update the available fields, it's not going to suit.

The field names shouldn't change. It's conceivable that from time to time we might add a new one (if we start selling a product with variable height or colour for example), and in that situation it's not unreasonable to manually set it up but the general day-t-day processing shouldn't require it.
  1. more than a month ago
  2. RO CSVI
  3. # 10
Accepted Answer Pending Moderation
I think I've been approaching this wrong, but it still looks like there's a problem.
Instead of running an image import, I've updated this template so it imports the image and thimbnail. My current problem is that despite 'process images' being disabled under general options, and a thumbnail entry in the csv file of "tMYL-125-A4-001.png" the used url thumb is "images/vm/resized/FAB/125MIC_150x150.jpg"
  1. more than a month ago
  2. RO CSVI
  3. # 11
Accepted Answer Pending Moderation
Hello,
Thanks for your response, and apologies for the delay in mine. I'll try what you've suggested this afternoon, but it raises a concern: I want to be able to automate the import of these files. I can do that with cron jobs and shell scripts, but if I have to log into the site every time we try to update it to manually update the available fields, it's not going to suit.
The field names shouldn't change. It's conceivable that from time to time we might add a new one (if we start selling a product with variable height or colour for example), and in that situation it's not unreasonable to manually set it up but the general day-t-day processing shouldn't require it.

You really don't have to update your available fields manually. You can set up a cron for maintenance task to updating your available fields and run this cron before running your product import.

I think I've been approaching this wrong, but it still looks like there's a problem.
Instead of running an image import, I've updated this template so it imports the image and thimbnail. My current problem is that despite 'process images' being disabled under general options, and a thumbnail entry in the csv file of "tMYL-125-A4-001.png" the used url thumb is "images/vm/resized/FAB/125MIC_150x150.jpg"

Can you post your latest debug log to check? To know on how to get the debug log check the blue box on top of this page.
Kind regards,

Tharuna

=========================
If you use CSVI, please post a rating and a review at the Joomla! Extension Directory
  1. more than a month ago
  2. RO CSVI
  3. # 12
Accepted Answer Pending Moderation
Hi Tharuna,

Thanks; I've emailed you the log like last time. Please let me know if it doesn't arrive.
  1. more than a month ago
  2. RO CSVI
  3. # 13
Accepted Answer Pending Moderation
Hello,
Thank you for sending the debug log file. For the issue that thumbnail image not imported as in CSV file, can you load the attached patch file and then try running the import?

patch_vm_2017_12_05.zip
Attachments (1)
Kind regards,

Tharuna

=========================
If you use CSVI, please post a rating and a review at the Joomla! Extension Directory
  1. more than a month ago
  2. RO CSVI
  3. # 14
Accepted Answer Pending Moderation
Hi Tharuna,

That's much closer - it's now showing the used thumb url as images/vm/FAB/resized/t125MIC.png, but it should be images/vm/FAB/t125MIC.png.
  1. more than a month ago
  2. RO CSVI
  3. # 15
Accepted Answer Pending Moderation
Hello,
VirtueMart always stored the thumbnail images in resize folder and so your thumbnail image path has been saved with resize folder. If you don't want to have resize folder in the image path then you need to have full path for your thumbnail image as images/vm/FAB/t125MIC.png in file_url_thumb field.
Kind regards,

Tharuna

=========================
If you use CSVI, please post a rating and a review at the Joomla! Extension Directory
  1. more than a month ago
  2. RO CSVI
  3. # 16
Accepted Answer Pending Moderation
Previous versions didn't force us to use the 'resized' folder. The thumbnail location was relative to the main image location, so if the "Location product files" config was set to "images/vm/"
and the main image field contained:
"FAB/MYL-125-A4-001.jpg"
and the thumbnail field contained:
"tMYL-125-A4-001.png"
They'd be found at:
images/vm/FAB/MYL-125-A4-001.jpg
and
images/vm/FAB/tMYL-125-A4-001.png

If we can still achieve what we need with full paths I'll give that a try but it's not how we ever used older versions of the software.

Thanks.
  1. more than a month ago
  2. RO CSVI
  3. # 17
Accepted Answer Pending Moderation
Hello,
As you are saying yourself the old version of VirtueMart may not be forcing to have resize folder but that is not the case with latest or newer versions. You can try saving an image manually from VirtueMart products page. By default VirtueMart stores thumbnail images in resize folder.
Kind regards,

Tharuna

=========================
If you use CSVI, please post a rating and a review at the Joomla! Extension Directory
  1. more than a month ago
  2. RO CSVI
  3. # 18
Accepted Answer Pending Moderation
Ok, I've tried that, but to do so I need to empty the "Location product files" field, but it defaults to "images/stories/virtuemart/product/" which is wrong.
I tried replacing it with "/", but the two fields are now inconsistent:
used url contains: images/vm//FAB/MYL-125-A3-001.jpg
used thumb url contains: /images/vm/FAB/images/vm/FAB/tMYL-125-A2-001.png

sorry about this.
  1. more than a month ago
  2. RO CSVI
  3. # 19
Accepted Answer Pending Moderation
Hello,

Instead of putting a / in the field, you can put a dot. I believe that should work. You are one of the few that uses the same folder for both large and small images :)
  1. more than a month ago
  2. RO CSVI
  3. # 20
  • Page :
  • 1
  • 2


There are no replies made for this post yet.
Be one of the first to reply to this post!