1. skmccall
  2. RO CSVI
  3. Friday, 03 March 2017
  4.  Subscribe via email
I am trying to import products images into Virtuemart as part of a product file and it not working. The product is uploaded but I get message below.

"vmError: Couldnt create thumb, file not found "
vmError: File not found "

I have attached the log.
Accepted Answer Pending Moderation
Hello,
It looks like you are downloading a remote image and trying to create image name with product name field and converting the image type to png. The debug log shows that Image is not able to be converted. What if you don't try to convert the image to png? Can you give it a try? Also, attach your sample import file and debug log if you still have issues.
Kind regards,

Tharuna

=========================
If you use CSVI, please post a rating and a review at the Joomla! Extension Directory
  1. more than a month ago
  2. RO CSVI
  3. # 1
Accepted Answer Pending Moderation
I tried not converting the images but now it just uploaded blank images ( see screenshot). I have also attached the file I am importing and the new debug log from my last attempt.
Attachments (3)
  1. more than a month ago
  2. RO CSVI
  3. # 2
Accepted Answer Pending Moderation
Hello,
So it shows that image has been created but not downloaded. Recently there were user coming with the same type of issues and the related thread is here. You can check if the solution helps you to solve the issue.
Kind regards,

Tharuna

=========================
If you use CSVI, please post a rating and a review at the Joomla! Extension Directory
  1. more than a month ago
  2. RO CSVI
  3. # 3
Accepted Answer Pending Moderation
Hi, So I tired 5 different external sources same result, so either they are all blocking me or it is something else. Are you able to download the images successfully using my file?
  1. more than a month ago
  2. RO CSVI
  3. # 4
Accepted Answer Pending Moderation
Hello,
Are you able to download the images successfully using my file?

Yes, i am able to run your file here and can download the images. See screenshot. I guess you may be blocked by remote host or something is wrong with settings on your server.
Attachments (1)
Kind regards,

Tharuna

=========================
If you use CSVI, please post a rating and a review at the Joomla! Extension Directory
  1. more than a month ago
  2. RO CSVI
  3. # 5
Accepted Answer Pending Moderation
one more thing, I also tried downloading images from my own website and got the same result.
  1. more than a month ago
  2. RO CSVI
  3. # 6
Accepted Answer Pending Moderation
Since I got the same results when I used images from another one of my sites I am guessing I am not blocked. Can you let me know what settings could cause this, so I can check them? What should the settings be?
  1. more than a month ago
  2. RO CSVI
  3. # 7
Accepted Answer Pending Moderation
Hello,

Since you changed some settings, can you post me your most recent debug log?
  1. more than a month ago
  2. RO CSVI
  3. # 8
Accepted Answer Pending Moderation
Here you go!
Attachments (1)
  1. more than a month ago
  2. RO CSVI
  3. # 9
Accepted Answer Pending Moderation
Hello,

So let's see what is in the debug log.
2017-03-04 03:37:16 1 [DEBUG] Process image file
2017-03-04 03:37:16 1 [DEBUG] Current file: /.../gallexy/images/stories/virtuemart/product/Test Product Image 2.jpg
2017-03-04 03:37:16 1 [DEBUG] Remote file stored: http://www.goldenflair.com/images/headers/closed_eyes_resized.jpg --> /.../gallexy/tmp/com_csvi/closed_eyes_resized.jpg
2017-03-04 03:37:16 1 [DEBUG] Identity string:
2017-03-04 03:37:16 1 [DEBUG] Mime type found:
2017-03-04 03:37:16 1 [DEBUG] Source extension is and target extension is jpg
2017-03-04 03:37:16 1 [DEBUG] Renaming full image because bad extension: /.../gallexy/tmp/com_csvi/closed_eyes_resized.jpg --> /.../gallexy/tmp/com_csvi/closed_eyes_resized..
2017-03-04 03:37:16 1 [DEBUG] Full name original: /.../gallexy/tmp/com_csvi/closed_eyes_resized..
2017-03-04 03:37:16 1 [DEBUG] Full name target: images/stories/virtuemart/product/Test Product Image 2.jpg
2017-03-04 03:37:16 1 [DEBUG] Store remote file on server /.../gallexy/tmp/com_csvi/closed_eyes_resized.. --> /.../gallexy/images/stories/virtuemart/product/Test Product Image 2.jpg
2017-03-04 03:37:16 1 [DEBUG] Check original file: /.../gallexy/images/stories/virtuemart/product/Test Product Image 2.jpg
2017-03-04 03:37:16 1 [DEBUG] Identity string:
2017-03-04 03:37:16 1 [DEBUG] Create thumbnail from /.../gallexy/images/stories/virtuemart/product/Test Product Image 2.jpg to /.../gallexy/images/stories/virtuemart/product/resized/Test Product Image 2.jpg
2017-03-04 03:37:16 1 [DEBUG] Thumnail has not been created because the image cannot be converted

You are not being blocked because the file is accessible. First of all it creates the new filename based on the product name and we get this /.../gallexy/images/stories/virtuemart/product/Test Product Image 2.jpg. Next the external file is downloaded to /.../gallexy/tmp/com_csvi/closed_eyes_resized.jpg. The next step for CSVI is to determine what kind of image it is and that is where it goes wrong. The debug log shows an empty identity string and an empty mime-type, things go sideways from there.

This raises a few questions. Could CSVI actually store the external image in the location specified? Does the tmp/com_csvi folder have the correct permissions? If the image can be stored what is the file size of the image?

Something else I wanted to ask, is there any reason why you are renaming the images to the product name? The reason I am asking is because it could potentially create invalid filenames.
  1. more than a month ago
  2. RO CSVI
  3. # 10
Accepted Answer Pending Moderation
Hi,

tmp/com_csvi has permissions 755. As for the filename, I am renaming the image to make it easier to associate the image to the product. However I tried it with rename turn off and got the same result. See import file and log attached.
Attachments (2)
  1. more than a month ago
  2. RO CSVI
  3. # 11
Accepted Answer Pending Moderation
Hello,

The renaming is not related to the issue, I was just wondering.

One question you haven't answered yet. If the image can be stored what is the file size of the image? I am thinking that there is an issue with that.
  1. more than a month ago
  2. RO CSVI
  3. # 12
Accepted Answer Pending Moderation
Most of the images i have tried so far have been pretty small, they have all under 5 mb.
  1. more than a month ago
  2. RO CSVI
  3. # 13
Accepted Answer Pending Moderation
Hello,
Did you check the link for the thread i posted earlier? The user had same problem and have given the solution that he set allow_url_fopen on "on". What is in your setting? Can you check?
Kind regards,

Tharuna

=========================
If you use CSVI, please post a rating and a review at the Joomla! Extension Directory
  1. more than a month ago
  2. RO CSVI
  3. # 14
Accepted Answer Pending Moderation
I looked at the thread and none of that seems applicable, I don't have time out and size problems.
  1. more than a month ago
  2. RO CSVI
  3. # 15
Accepted Answer Pending Moderation
Hello,
Can you post screenshot of file size of your images downloaded and stored with import?
Kind regards,

Tharuna

=========================
If you use CSVI, please post a rating and a review at the Joomla! Extension Directory
  1. more than a month ago
  2. RO CSVI
  3. # 16
Accepted Answer Pending Moderation
I don't think I understand, the images won't upload, that is the problem.
  1. more than a month ago
  2. RO CSVI
  3. # 17
Accepted Answer Pending Moderation
Hello,

Yes, that is exactly the problem. The images cannot be stored from the external server onto your server. So the question is why can't CSVI save the images on your server? That is why I asked what the file size of the image is that is stored on your server. The 5MB size is the size of the original file I guess and not the size of the image on your server.
  1. more than a month ago
  2. RO CSVI
  3. # 18
Accepted Answer Pending Moderation
So I downloaded some of the images manually and uploaded them ( screenshot attached). Since I can upload it manually I don't think the size is the issue.
Attachments (1)
  1. more than a month ago
  2. RO CSVI
  3. # 19
Accepted Answer Pending Moderation
Hello,

I assume you were not logged in as the webserver user, so you can't really compare uploading manually with downloading them as the webserver user. I don't know in what other way I can ask to show me how the image files are stored that are downloaded during import as you keep giving me unrelated info. Let me try the following question: Do you see any images on your server that were downloaded during import?
  1. more than a month ago
  2. RO CSVI
  3. # 20
  • Page :
  • 1
  • 2


There are no replies made for this post yet.
Be one of the first to reply to this post!