1. piosaliani
  2. RO CSVI
  3. Tuesday, 29 September 2020
  4.  Subscribe via email
Hello,
I imported the csv file that I am attaching to you, I uploaded in ftp the images of the products of the "TRILBY TESSUTO" category http://www.cappelleriaartigianale.it/index.php/uomo/uomo-invernale/trilby-tessuto (see attached prodotti_29092020_1 .zip, prodotti_29092020_2 .zip), but all products in the TRILBY TESSUTO category have the preview images but not the enlarged images (see attached enlarged_image1.jpg and enlarged_image2.jpg).
There must be some problems in the import.

Best regards
Pio
Attachments (6)
Accepted Answer
Accepted Answer Pending Moderation
Hello Pio,
I checked your site to find the actual cause for this issue and i did find it. It is not RO CSVI import issue. With RO CSVI import file_url is updated in database and media is linked to the product(see screenshots). The problem is with VirtueMart checking if the image exists. VirtueMart checks for the image as

/web/htdocs/http://www.cappelleriaartigianale.it/home/images/virtuemart/product/UT116_V1.jpg

but your image is UT116_V1.JPG. Note the extension of the image. VirtueMart thinks that image does not exists and so does not show the file_url in Used URL field. The strange part is that this check is only on file_url field and not on file_url_thumb. You need to convert the image extensions to lowercase and import it so VirtueMart can find your images.
Attachments (2)
Kind regards,

Tharuna

=========================
If you use CSVI, please post a rating and a review at the Joomla! Extension Directory
Accepted Answer Pending Moderation
Hello Pio,
As per the debug log the images have been linked to the product. I don't see any problem with the import. But i see that you are using VirtueMart 3.8.4 version. In this version VirtueMart has introduced some new fields for tracking if the product has images, categories, manufacturers and shoppers linked. We have added support for these new fields in RO CSVI 7.17.0 version. Since you are using 7.16.1 version, please update to RO CSVI 7.17.0 version and run the import again. See if that helps with the images.
Kind regards,

Tharuna

=========================
If you use CSVI, please post a rating and a review at the Joomla! Extension Directory
  1. 4 weeks ago
  2. RO CSVI
  3. # 1
Accepted Answer Pending Moderation
Hi Tharuna,
We have updated ro csvi, re-imported the products, but the problem persists.
The strange thing is that for some products the image enlargement works (for example the product with sku BN098_V1), for others it doesn't, as for all the products of the "Trilby Tessuto" category.

Best Regards
Pio
Attachments (1)
  1. 4 weeks ago
  2. RO CSVI
  3. # 2
Accepted Answer Pending Moderation
Hello Pio,
I looked into your site to check the difference between a product with sku UT159_V1_MORO_BLUE in "Trilby Tessuto" category and product BN098_V1. The difference is that Used url field is empty in Product Images tab in VirtueMart Products page for UT159_V1_MORO_BLUE product. See the attached screenshots. This is the reason why the main image is not available on frontend. So i looked into the debug log to see the query which runs for the main image for both of these products. The query does update the file_url (main image ) field for UT159_V1_MORO_BLUE product. Please check the query taken from the debug log. Now the question is when and why does this field gets empty. There is nothing wrong with the query to say the record is not updated. If you check the Used url field for product UT159_V1_MORO_BLUE right after the import, is it empty? From what i can see there is no problem with RO CSVI import. What if you run this query from PhpMyAdmin?


UPDATE `v64ze_virtuemart_medias` SET `virtuemart_vendor_id`='1',`file_title`='',`file_description`='',`file_meta`='',`file_class`='',`file_mimetype`='image/jpeg',`file_type`='product',`file_url`='images/virtuemart/product/UT159_V1_MORO_BLUE.JPG',`file_url_thumb`='images/virtuemart/product/UT159_V1_MORO_BLUE.JPG',`file_is_product_image`='1',`file_is_downloadable`='0',`file_is_forSale`='0',`file_params`='',`file_lang`='',`shared`='0',`published`='1',`created_on`='0000-00-00 00:00:00',`created_by`='0',`modified_on`='0000-00-00 00:00:00',`modified_by`='0',`locked_on`='0000-00-00 00:00:00',`locked_by`='0' WHERE `virtuemart_media_id` = '1379'
Attachments (2)
Kind regards,

Tharuna

=========================
If you use CSVI, please post a rating and a review at the Joomla! Extension Directory
  1. 4 weeks ago
  2. RO CSVI
  3. # 3
Accepted Answer Pending Moderation
Hi Tharuna,
I ran the query in phpmyadmin, it doesn't return errors (see attached query.jpg), and in the table "v64ze_virtuemart_medias", I see the fields "file_url" and "file_url_thumb" filled in (see attached table.jpg).
If I see the site the UT159_V1_MORO_BLUE product does not have the large jpg image.
However, I don't see any differences between products in the "file_url" fields of the csv.
If I replace the image directly from the joomla admin panel, the image is loaded, this test I did the other time.
Virtuemart seems to work fine

Best Regards
Pio
Attachments (3)
  1. 4 weeks ago
  2. RO CSVI
  3. # 4
Accepted Answer Pending Moderation
Hello Pio,
I ran the query in phpmyadmin, it doesn't return errors (see attached query.jpg), and in the table "v64ze_virtuemart_medias", I see the fields "file_url" and "file_url_thumb" filled in (see attached table.jpg).
If I see the site the UT159_V1_MORO_BLUE product does not have the large jpg image.

Do you mean even after running the update query you don't see the image on frontend?

However, I don't see any differences between products in the "file_url" fields of the csv.

Yes you file is good. I ran the import with your file and images. Import went good. I was able to see the images on frontend for "Trilby Tessuto" category. See attached screenshot.

If I replace the image directly from the joomla admin panel, the image is loaded, this test I did the other time.
Virtuemart seems to work fine

There is nothing wrong with the import or atleast it won't happen only for one specific category. The issue is that file_url field being empty in VirtueMart admin. As i said the query in debug log shows that file_url field has been updated. Is there anything specific set for this category in VirtueMart for this category?
You can try running the import on a test site with VirtueMart and RO CSVI and see how that goes.
Attachments (2)
Kind regards,

Tharuna

=========================
If you use CSVI, please post a rating and a review at the Joomla! Extension Directory
  1. 4 weeks ago
  2. RO CSVI
  3. # 5
Accepted Answer Pending Moderation
Hi Tharuna,
"Do you mean even after running the update query you don't see the image on frontend?"
no, after running the query on the frontend the image was not present.
"Is there anything specific set for this category in VirtueMart for this category?"
No, it is set like the other categories.
We have repeated the import twice, if now you tell me that it was successful, the thing is very strange, because the next import may not work.

Best Regards
Pio
  1. 4 weeks ago
  2. RO CSVI
  3. # 6
Accepted Answer Pending Moderation
Hello Pio,
no, after running the query on the frontend the image was not present.

If the image file is updated to file_url field it should show on frontend. I would think this to be more of cache issue.

We have repeated the import twice, if now you tell me that it was successful, the thing is very strange, because the next import may not work.

My bad, i did not mention that import worked on my test site and those screenshots are from my test site. That is to say that there is nothing wrong with your import file nor there is any problem with RO CSVI to process the image.

As requested please test the import on a test site to see how that goes. That will also confirm if there is something specific on your site which is emptying file_url field.
Kind regards,

Tharuna

=========================
If you use CSVI, please post a rating and a review at the Joomla! Extension Directory
  1. 4 weeks ago
  2. RO CSVI
  3. # 7
Accepted Answer Pending Moderation
Hi Tharuna,
I need to find a test server where to load the site.
However I still do not see the images of the products in the "Trilby Tessuto" category.

Best Regards
Pio
  1. 4 weeks ago
  2. RO CSVI
  3. # 8
Accepted Answer Pending Moderation
Hi Tharuna,
if i wanted to explain the problem to my provider, to check if there are problems on the server, what could i write?

Thanks
Pio
  1. 4 weeks ago
  2. RO CSVI
  3. # 9
Accepted Answer Pending Moderation
Hello Pio,
if i wanted to explain the problem to my provider, to check if there are problems on the server, what could i write?

I really don't think this is a problem with your server. I am thinking more this as a VirtueMart configuration. If it is a problem with your server or RO CSVI import then the issue won't be with one single category.

However I still do not see the images of the products in the "Trilby Tessuto" category.

To test more on this, can you take two products of "Trilby Tessuto" category and run the import? It won't make any difference with import but atleast we can check on what is going on after import with VirtueMart.
Kind regards,

Tharuna

=========================
If you use CSVI, please post a rating and a review at the Joomla! Extension Directory
  1. 4 weeks ago
  2. RO CSVI
  3. # 10
Accepted Answer Pending Moderation
Hi Tharuna,
I imported a csv (see attachment) with only three products in the "Trilby Tessuto" category. The problem persists.
We noticed that even in the "Cappello Tessuto Estivo" category there is the same problem with the product with sku 83479_V3_PERLA (see attachment).

Best Regards
Pio
Attachments (3)
  1. 4 weeks ago
  2. RO CSVI
  3. # 11
Accepted Answer Pending Moderation
Hello Pio,
I imported a csv (see attachment) with only three products in the "Trilby Tessuto" category. The problem persists.

I am really out of ideas on why this is happening. As per the debug log there is nothing wrong with the import. As I said earlier please test this on a fresh Joomla installation with VirtueMart and RO CSVI installed.

We noticed that even in the "Cappello Tessuto Estivo" category there is the same problem with the product with sku 83479_V3_PERLA (see attachment).

Checking previous debug log shows that file_url has been updated for this product too.
Kind regards,

Tharuna

=========================
If you use CSVI, please post a rating and a review at the Joomla! Extension Directory
  1. 3 weeks ago
  2. RO CSVI
  3. # 12
Accepted Answer Pending Moderation
Hi Tharuna,
If I try the import on a test site, without creating the same categories in virtuemart present on cappelleriaartigianale.it, is the import successful?
Are the categories automatically created in virtuemart?
This test site uses the same template (the graphics are obviously different), php 5.6.40, Joomla 3.8.8, VirtueMart 3.2.12.
So let's see if it's a problem of joomla and virtuemart versions.

Best Regards
Pio
  1. 3 weeks ago
  2. RO CSVI
  3. # 13
Accepted Answer Pending Moderation
Great Tharuna !!
Really the best !!
Congratulations on the professionalism!!

Thanks so much!!
Pio
  1. 3 weeks ago
  2. RO CSVI
  3. # 14
  • Page :
  • 1


There are no replies made for this post yet.
Be one of the first to reply to this post!