1. raydekker
  2. RO CSVI
  3. Friday, 31 March 2017
  4.  Subscribe via email
I'm Ray from Australia and I've been away for a while but now very close to launching my pc builder and shop (as in advertising it here).
You can have a look if you want:
The shop beta: http://www.btechsolutions.com.au/shop
The PC-Builder beta: http://www.btechsolutions.com.au/pcbuilder

The problem I'm having now is:
There is no "Add to cart" button for my child products.
I can fix this by going to backend > Virtuemart > Products > Custom Fields tab > and tick all the "disable derived product" boxes for each string and plugin. This way "Add to cart" will be shown for each child product too.
My question is: How do I implement this within CSVI, what field do I add and where so this happens during import??
So that for my child products all these boxes are ticked, actually for every product would be fine as the non-child products haven't got custom fields anyway.

I found a topic on the forum about doing this for the override tickbox but Roland created a patch file but this should have been solved in a later version.

Please find attached some screenshots of the matter.
Accepted Answer Pending Moderation
Hello Ray,
You need to use custom_disabler field in your product import to disable derived products. The use of this field is also explained in product with custom fields import document.
Kind regards,

Tharuna

=========================
If you use CSVI, please post a rating and a review at the Joomla! Extension Directory
  1. more than a month ago
  2. RO CSVI
  3. # 1
Accepted Answer Pending Moderation
Thanks Tharuna, awesome that there's a solutions (I assume).
However, I'm having trouble getting the "custom_disabler" field to tick the boxes I want in VM > Products > Child Products > Custom Fields > Derived checkbox (as in the attached screenshot in 6the original post).

I've tried the following values for the field: Y, y, 1, N, n, 0 but all the same: None of the "d" checkboxes per product are ticked.

I've uploaded the log file of the product import to my Google Drive, I've removed lines 24-184 and 285-600ish to make the file smaller (original 10MB, cropped 2MB), the lines that matter are 192-222 (that's got the above fields in them but fails to check the tickboxes...)
Log file from Google Drive: https://drive.google.com/file/d/0B5YNB4V34wWtQzBudVFrcmdXWDA/view?usp=sharing

I hope this helps and I'm just missing out something "silly" :)

Best regards, Ray
  1. more than a month ago
  2. RO CSVI
  3. # 2
Accepted Answer Pending Moderation
Hello Ray,
The disabler field as per your debug log has been updated with 0 but it should be id of the parent product. Can you also post your import file to check?
Kind regards,

Tharuna

=========================
If you use CSVI, please post a rating and a review at the Joomla! Extension Directory
  1. more than a month ago
  2. RO CSVI
  3. # 3
Accepted Answer Pending Moderation
"...it should be the id of the parent product"? Do you mean, instead of Y or N it should be the parent id? Which I can easily setup in my excel file but I don't think we are on the same page yet, I don't think that's what you mean.

I hope my import file helps you. Please find attached the import file and my excel file with ALL my tabs that get exported as csv files to get imported via a script on my server.

Thanks

Import file in CSV (which is sheet 2 of my excel file):
[attachment]2) VM Cat & Prod.zip[/attachment]

Excel file with ALL the sheets (and export macro etc), you shouldn't need this but just in case:
[attachment]Categories & Products.zip[/attachment]
Attachments (2)
  1. more than a month ago
  2. RO CSVI
  3. # 4
Accepted Answer Pending Moderation
Hello Ray,
"...it should be the id of the parent product"? Do you mean, instead of Y or N it should be the parent id? Which I can easily setup in my excel file but I don't think we are on the same page yet, I don't think that's what you mean.

No, that is not what i meant. If custom_disabler is set to Y, CSVI will automatically assign the parent id but it is not working in your case and instead it was updating the disabler field as 0. The cause for this problem is we don't have support for custom_disabler field for stockablecustomfields yet. I am adding this support and will send the patch when done.
Kind regards,

Tharuna

=========================
If you use CSVI, please post a rating and a review at the Joomla! Extension Directory
  1. more than a month ago
  2. RO CSVI
  3. # 5
Accepted Answer Pending Moderation
Hi,

Ah ok, I'm glad you found out what is causing the tickboxes not to be ticked! :)
And yes I am using the stockablecustomfields addon for my product builder addon (I should have added that info I guess ;) ).

Ok, looking forward to the patch file,
Thank you very much!

Best regards, Ray
  1. more than a month ago
  2. RO CSVI
  3. # 6
Accepted Answer Pending Moderation
Hello Ray,
The patch file for supporting custom_disabler field for stockablecustomfields is ready. Can you try to load the attached patch file and run the import using custom_disabler fields for products as in the example given below? Let me know on how it goes.


"product_sku","product_parent_sku","custom_title","custom_value","custom_multiple","product_name","product_price","custom_disabler"
"10001","","Size and Color~Size and Color~Size and Color","stockablecustomfields~stockablecustomfields~stockablecustomfields","Y~Y~Y","Parent product","123","Y~N~Y"
"10001brbl","10001","Size~Color","M~Green",,"Child Medium Green",
"10001brge","10001","Size~Color","L~Red",,"Child Large Red",
"10001bror","10001","Size~Color","XL~Orange",,"Child Extra Large Orange",



patch_SCF_2017_04_21.zip
Attachments (1)
Kind regards,

Tharuna

=========================
If you use CSVI, please post a rating and a review at the Joomla! Extension Directory
  1. more than a month ago
  2. RO CSVI
  3. # 7
Accepted Answer Pending Moderation
Hi Tharuna,

I've loaded the patch file and by the looks of it it partially works while importing.
Please find attached the screenshots of what the "disable derived CF for child product" tickboxes look like, as you can see only some are ticked and if I look further into it, the ones that are NOT ticked are called "inherited" instead of "COM_VIRTUEMART_CUSTOM_DISABLED"

When I manually tick the remaining tickboxes (so the ones labeled "inherited";) and click "save" then all of a sudden they are all called "COM_VIRTUEMART_CUSTOM_DISABLED" and after that it works... as you can see too in the screenshots.

The attachments labeled "after patch and import" are the ones directly after applying the patch and the new import.
The attachments labeled "example working" are the ones where I manually ticked the remaining boxes to get it to work.

Please find the log file and the original import excel file (which becomes separate CSV files) on my Google Drive:
https://drive.google.com/drive/folders/0B5YNB4V34wWtMWxCM0xhZzBzRlU?usp=sharing
As the log file is 13MB and my Excel file is 560KB. It's also got the screenshots in it.

Hope this helps, it's somehow "inheriting" CUSTOM_DISABLED fields instead of overwriting them with "YES" or "1".

Best regards, Ray
Attachments (4)
  1. more than a month ago
  2. RO CSVI
  3. # 8
Accepted Answer Pending Moderation
Hello Ray,
Can you also please post the screenshot on how you have your stockable custom fields set up on VirtueMart Custom fields page? I tried disabling the checkbox manually and for me it doesn't change to "COM_VIRTUEMART_CUSTOM_DISABLED" and still stays as inherited so need to check what i am missing with settings. It would be great if you can send me mysql dump of your #__virtuemart_customs table.
Kind regards,

Tharuna

=========================
If you use CSVI, please post a rating and a review at the Joomla! Extension Directory
  1. more than a month ago
  2. RO CSVI
  3. # 9
Accepted Answer Pending Moderation
Hi Tharuna, yes I've just tried it again and as soon as I tick the remaining tickboxes AND press "save" it changes to "COM_VIRTUEMART_CUSTOM_DISABLED".
Please find attached the screenshots of the custom fields in VM as requested.
You can also find the custom fields in tab 1 of my excel file attached in earlier posts (the Google Drive link).

See product "Kingston SSDNow UV400 120GB SSD" has got the "Add to Cart" button enabled now:
https://www.btechsolutions.com.au/shop/storage/ssds-2-5

Also please find attched the requested mySQL dump for the virtuemart_customs table.

Best regards, Ray
Attachments (3)
  1. more than a month ago
  2. RO CSVI
  3. # 10
Accepted Answer Pending Moderation
Hello Ray,
Thank you so much for sending the requested details. I am still not able to see the option "COM_VIRTUEMART_CUSTOM_DISABLED" with your custom fields and importing your import file. I am not sure on what is missing. If possible, can you send me your site login details to check? Please also send me your database access details.
Kind regards,

Tharuna

=========================
If you use CSVI, please post a rating and a review at the Joomla! Extension Directory
  1. more than a month ago
  2. RO CSVI
  3. # 11
Accepted Answer Pending Moderation
Hi Tharuna, please check your email, I've emailed the logins to tharuna@csvimproved.com

Hope this helps, for example play around with the SSD drives (what I did) in Storage>SSD 2.5>Kingston...
  1. more than a month ago
  2. RO CSVI
  3. # 12
Accepted Answer Pending Moderation
Hello,
The difference in your site and my test site settings is the VirtueMart version. You are running 3.0.18 version but i am on latest 3.2 version. The patch i posted was also developed based on this latest VirtueMart version and in this version there is no "COM_VIRTUEMART_CUSTOM_DISABLED" as VirtueMart enters empty customfield_params for custom_disabler row for stockablecustomfields. Would appreciate if you can test the patch with latest VirtueMart version. My advise would be create a test site which is the duplicate of your live site, update your VirtueMart version, apply the patch and then run the import. If everything goes well then you can run the same on live site.
Kind regards,

Tharuna

=========================
If you use CSVI, please post a rating and a review at the Joomla! Extension Directory
  1. more than a month ago
  2. RO CSVI
  3. # 13
Accepted Answer Pending Moderation
Thank you very much for fixing this!
The problem has been fixed with the latest patch file and will be in the next update.
So now all the "disbale derived" tickboxes in VM > Products > Custom Fields are ticked, so I get the "Add to Cart" button displayed in our shop.

Issue we've experienced in between:
VM 3.2.0 seemed to work with the first patch file but not VM 3.2.1.
With the latest patch file (15/05/2017) it also works on VM 3.2.1.

The other problem I had was to do with VM category filter dropdown menu in VM > Products. This should be fixed with VM 3.2.2 apparently as I'm somehow running in "fallback" mode, so it has to do with language settings. I'm only running one language so it's not 100% clear to me but we'll see :)

Thanks again, Ray
  1. more than a month ago
  2. RO CSVI
  3. # 14
  • Page :
  • 1


There are no replies made for this post yet.
Be one of the first to reply to this post!