1. sabikeuk
  2. RO CSVI
  3. Friday, 11 September 2020
  4.  Subscribe via email
Hello,

I am trying to export products from Virtuemart, I have used same template setting/fields from another website where all is working fine. I am able to export always only 1 product (I have tried to select different manufacturers but always only 1 products is exported).

I am attached log.

Can you please advise ?

Kind regards,
Daniel
Attachments (1)
Accepted Answer
Accepted Answer Pending Moderation
Hello Tharuna,

yes, the problem was due to Joomla debug mode turn on. I just compared settings of my two sites and found the difference in Joomla debug mode, once turn off its all working as supposed to be.

Kind regards,
Daniel
  1. one week ago
  2. RO CSVI
  3. # Permalink
Accepted Answer Pending Moderation
Hello Daniel,
In the attached debug log filter is set to export products with manufacturer with id 9. Does this manufacturer have more than one product?

When you export, is it the same product included always in export file? I am asking this because we had users having the same one record in export problem before so please check the below to see if you have the same issue.

1. Is the new site where you used the template from another site on same server or another server?
2. In Joomla configuration page on server tab see if Database type is set to MySQLi.
3. In RO CSVI About page check if Database Iterator Support is set to Yes.
4. Tell us which MySQL version you are using.
Kind regards,

Tharuna

=========================
If you use CSVI, please post a rating and a review at the Joomla! Extension Directory
  1. 2 weeks ago
  2. RO CSVI
  3. # 1
Accepted Answer Pending Moderation
Hello Tharuna,

see my replies, I believe problem is with Database Iterator Support as its set to NO, on my other website its set to YES:


A. Does this manufacturer have more than one product? - yes - 240 products

B. When you export, is it the same product included always in export file? Yes - same from the selected manufacturer

1. Is the new site where you used the template from another site on same server or another server? same server
2. In Joomla configuration page on server tab see if Database type is set to MySQLi. - set to MySQLi
3. In RO CSVI About page check if Database Iterator Support is set to Yes. - its set to NO
4. Tell us which MySQL version you are using. 8.0.17


Kind regards,
Daniel
  1. 2 weeks ago
  2. RO CSVI
  3. # 2
Accepted Answer Pending Moderation
Hello Daniel,
I believe problem is with Database Iterator Support as its set to NO, on my other website its set to YES:

Yes that is the problem. The connection to database is lost after exporting one record and so you see only one record in the export file. If both the sites are on same server then database server settings should be the same. There is something different in these two sites which is killing the MySQL connection after one record in one of the site.

Few more things to check.
1. Are you seeing this one record in export only in this export or on other exports too? Please try to create any other export template and see if it works.
2. Just to be sure, You can run the below query in PHPMyAdmin and see if you get those 240 records. Please replace #__ to table prefix before running the query.


SELECT `#__virtuemart_products`.`virtuemart_product_id`,
`#__virtuemart_products`.`product_parent_id`,
`product_sku`,
`#__virtuemart_manufacturers_hu_hu`.`mf_name`,
`product_availability`,
`#__virtuemart_currencies`.`currency_code_3`,
`#__virtuemart_product_prices`.`virtuemart_shoppergroup_id`,
`product_in_stock`,
`#__virtuemart_product_prices`.`product_price`,
`product_weight`,
`#__virtuemart_products`.`virtuemart_product_id` AS `main_product_id`,
`#__virtuemart_product_categories`.`virtuemart_category_id`,
`product_override_price`,
`product_tax_id`,
`product_special`,
`product_discount_id`,
`#__virtuemart_products`.`product_params`,
`product_params`,
`#__virtuemart_products`.`published`
FROM `#__virtuemart_products`
LEFT JOIN `#__virtuemart_product_prices` ON `#__virtuemart_products`.`virtuemart_product_id` = `#__virtuemart_product_prices`.`virtuemart_product_id`
LEFT JOIN `#__virtuemart_product_manufacturers` ON `#__virtuemart_products`.`virtuemart_product_id` = `#__virtuemart_product_manufacturers`.`virtuemart_product_id`
LEFT JOIN `#__virtuemart_manufacturers` ON `#__virtuemart_product_manufacturers`.`virtuemart_manufacturer_id` = `#__virtuemart_manufacturers`.`virtuemart_manufacturer_id`
LEFT JOIN `#__virtuemart_manufacturers_hu_hu` ON `#__virtuemart_product_manufacturers`.`virtuemart_manufacturer_id` = `#__virtuemart_manufacturers_hu_hu`.`virtuemart_manufacturer_id`
LEFT JOIN `#__virtuemart_product_categories` ON `#__virtuemart_products`.`virtuemart_product_id` = `#__virtuemart_product_categories`.`virtuemart_product_id`
LEFT JOIN `#__virtuemart_currencies` ON `#__virtuemart_currencies`.`virtuemart_currency_id` = `#__virtuemart_product_prices`.`product_currency`
LEFT JOIN `#__virtuemart_product_shoppergroups` ON `#__virtuemart_product_shoppergroups`.`virtuemart_product_id` = `#__virtuemart_products`.`virtuemart_product_id`
WHERE #__virtuemart_products.published = 1 AND #__virtuemart_manufacturers.virtuemart_manufacturer_id IN ('9')
GROUP BY #__virtuemart_products.virtuemart_product_id


3. What if you install the export template and run the export on a clean Joomla install? Check if you get all records in this test install.
Kind regards,

Tharuna

=========================
If you use CSVI, please post a rating and a review at the Joomla! Extension Directory
  1. 2 weeks ago
  2. RO CSVI
  3. # 3
Accepted Answer Pending Moderation
Hello,

yes I am able to export only 1 product all the time.

I have run query, here is the output error:
Screenshot 2020-09-12 at 07.11.42.png

Kind regards,
Daniel
Attachments (1)
  1. 2 weeks ago
  2. RO CSVI
  3. # 4
Accepted Answer Pending Moderation
Hello,

Go to the Global Configuration of your site and then the Server tab. Check that the database type is set to MySQLi. If not, you can set it to that and the iterator check should show you yes. Let us know how it goes.
Kind regards,

RolandD

=========================
If you use our extensions, please post a rating and a review at the Joomla! Extension Directory
  1. 2 weeks ago
  2. RO CSVI
  3. # 5
Accepted Answer Pending Moderation
Hello,

the database was set as MySQLi. I have run another query a here is the output from database:

mysql.png

Kind regards,
Daniel
Attachments (1)
  1. 2 weeks ago
  2. RO CSVI
  3. # 6
Accepted Answer Pending Moderation
Hello Daniel,
yes I am able to export only 1 product all the time.

You see only one product in fresh Joomla installation too?

The query in the first screenshot in your reply did not work as you have not replaced correct table prefix. The second query did not work because of MySQL version. Try the below query and see how it goes.


SELECT `jos_virtuemart_products`.`virtuemart_product_id`,
`jos_virtuemart_products`.`product_parent_id`,
`product_sku`,
`jos_virtuemart_manufacturers_hu_hu`.`mf_name`,
`product_availability`,
`jos_virtuemart_currencies`.`currency_code_3`,
`jos_virtuemart_product_prices`.`virtuemart_shoppergroup_id`,
`product_in_stock`,
`jos_virtuemart_product_prices`.`product_price`,
`product_weight`,
`jos_virtuemart_products`.`virtuemart_product_id` AS `main_product_id`,
`jos_virtuemart_product_categories`.`virtuemart_category_id`,
`product_override_price`,
`product_tax_id`,
`product_special`,
`product_discount_id`,
`jos_virtuemart_products`.`product_params`,
`product_params`,
`jos_virtuemart_products`.`published`
FROM `jos_virtuemart_products`
LEFT JOIN `jos_virtuemart_product_prices` ON `jos_virtuemart_products`.`virtuemart_product_id` = `jos_virtuemart_product_prices`.`virtuemart_product_id`
LEFT JOIN `jos_virtuemart_product_manufacturers` ON `jos_virtuemart_products`.`virtuemart_product_id` = `jos_virtuemart_product_manufacturers`.`virtuemart_product_id`
LEFT JOIN `jos_virtuemart_manufacturers` ON `jos_virtuemart_product_manufacturers`.`virtuemart_manufacturer_id` = `jos_virtuemart_manufacturers`.`virtuemart_manufacturer_id`
LEFT JOIN `jos_virtuemart_manufacturers_hu_hu` ON `jos_virtuemart_product_manufacturers`.`virtuemart_manufacturer_id` = `jos_virtuemart_manufacturers_hu_hu`.`virtuemart_manufacturer_id`
LEFT JOIN `jos_virtuemart_product_categories` ON `jos_virtuemart_products`.`virtuemart_product_id` = `jos_virtuemart_product_categories`.`virtuemart_product_id`
LEFT JOIN `jos_virtuemart_currencies` ON `jos_virtuemart_currencies`.`virtuemart_currency_id` = `jos_virtuemart_product_prices`.`product_currency`
LEFT JOIN `jos_virtuemart_product_shoppergroups` ON `jos_virtuemart_product_shoppergroups`.`virtuemart_product_id` = `jos_virtuemart_products`.`virtuemart_product_id`
WHERE jos_virtuemart_products.published = 1 AND jos_virtuemart_manufacturers.virtuemart_manufacturer_id IN ('9')
GROUP BY jos_virtuemart_products.virtuemart_product_id, `jos_virtuemart_products`.`product_parent_id`,`product_sku`,
`jos_virtuemart_manufacturers_hu_hu`.`mf_name`,
`product_availability`,
`jos_virtuemart_currencies`.`currency_code_3`,
`jos_virtuemart_product_prices`.`virtuemart_shoppergroup_id`,
`product_in_stock`,
`jos_virtuemart_product_prices`.`product_price`,
`product_weight`,
`jos_virtuemart_products`.`virtuemart_product_id`,
`jos_virtuemart_product_categories`.`virtuemart_category_id`,
`product_override_price`,
`product_tax_id`,
`product_special`,
`product_discount_id`,
`jos_virtuemart_products`.`product_params`,
`product_params`,
`jos_virtuemart_products`.`published`
Kind regards,

Tharuna

=========================
If you use CSVI, please post a rating and a review at the Joomla! Extension Directory
  1. 2 weeks ago
  2. RO CSVI
  3. # 7
Accepted Answer Pending Moderation
Hello Tharuna,

I dont have a possibility to check it on fresh joomla installation.

I have run another query, see below, I can see products from selected supplier (Housenordic).
Screenshot 2020-09-14 at 10.00.04.png

Kind regards,
Daniel
Attachments (1)
  1. 2 weeks ago
  2. RO CSVI
  3. # 8
Accepted Answer Pending Moderation
Hello Daniel,
You said you have two sites on same server where one of the site is working fine and in the other export is getting one record. Can you check and compare the settings between these two sites? Something is different in these two sites which makes makes the export break.
Kind regards,

Tharuna

=========================
If you use CSVI, please post a rating and a review at the Joomla! Extension Directory
  1. 2 weeks ago
  2. RO CSVI
  3. # 9
Accepted Answer Pending Moderation
Hello Tharuna,

I have found the reason, I had my other site in debug mode, turned it off and its working fine.

Thank you for your help!

Daniel
  1. 2 weeks ago
  2. RO CSVI
  3. # 10
Accepted Answer Pending Moderation
Hello Daniel,
Is it Joomla debug mode you turned off? Can you give us more details on how you solved it so we can help users coming with same issue in future?
Kind regards,

Tharuna

=========================
If you use CSVI, please post a rating and a review at the Joomla! Extension Directory
  1. 2 weeks ago
  2. RO CSVI
  3. # 11
  • Page :
  • 1


There are no replies made for this post yet.
Be one of the first to reply to this post!