1. infogate
  2. RO CSVI
  3. Saturday, 14 November 2020
  4.  Subscribe via email
Hello :)

I would like to ask about Google Merchant template.
I try to export my xml feed as the Google platform is available to Greece too, but to field "Shipping County" Greece is not available.
Is it possible to add it manually?
At the moment i use 7.3 version.
Thank you in advance :)
Accepted Answer
Accepted Answer Pending Moderation
Hello,
The problem is that the exported image link will not include the full site link as it show like that

Did you use picture_url field for image as i mentioned in my previous reply? Please post the export debug log to check.
Kind regards,

Tharuna

=========================
If you use CSVI, please post a rating and a review at the Joomla! Extension Directory
Accepted Answer Pending Moderation
Hello,
Is it possible to add it manually?

You cannot add it manually but with the attached patch file we have updated the shipping country list to all newly added countries in Google. Please load the attached patch file and check for Shipping country dropdown in export template.

At the moment i use 7.3 version.

We recommend to update to RO CSVI latest 7.18.0 version.
Attachments (1)
Kind regards,

Tharuna

=========================
If you use CSVI, please post a rating and a review at the Joomla! Extension Directory
  1. 2 weeks ago
  2. RO CSVI
  3. # 1
Accepted Answer Pending Moderation
Thank you very much for your fast reply and support.

I am trying to export a valid xml but when i set "SEF URL" to on the export will end to 502 Gateway error.
When i use no sef url there will be no image link exported.
I am trying to understand how this template works as if i create a normal export using the file_url i get the image link exported.

Once again thank you for your fast and reliable support.
  1. 2 weeks ago
  2. RO CSVI
  3. # 2
Accepted Answer Pending Moderation
Hello,
Thank you very much for your fast reply and support.

I am considering this feedback as patch file has solved the issue with Shipping country field.

I am trying to export a valid xml but when i set "SEF URL" to on the export will end to 502 Gateway error.

With SEF URL option RO CSVI generates product SEF URL using Joomla for each product in export. This process can take a lot of time when the number of products are more and could lead to this gateway error. So to avoid these kind of errors, we have a maintenance option to generate SEF URLs before and use these generated URLs in export. To generate SEF URLs beforehand, go to RO CSVI Maintenance page, select VirtueMart in first option and Refresh URLs in the second option. Select your export template and click on Continue. This will generate new SEF URLs and save it in database. You can then run the export and check if it finishes without any error.

When i use no sef url there will be no image link exported.

That is not possible. SEF URL and image are not dependent on each other. SEF is only on product_url field.

I am trying to understand how this template works as if i create a normal export using the file_url i get the image link exported.

I guess you want to export image with domain name, in that case you need to use picture_url field instead of file_url.

If you still have any issue, post the export debug log to check. To get the debug log check How to collect debug information? document.
Kind regards,

Tharuna

=========================
If you use CSVI, please post a rating and a review at the Joomla! Extension Directory
  1. 2 weeks ago
  2. RO CSVI
  3. # 3
Accepted Answer Pending Moderation
I just managed to get everything working normally without using the SEF cache.
The problem is that the exported image link will not include the full site link as it show like that


<g:image_link><![CDATA[images/stories/virtuemart/product/imagename.jpg]]></g:image_link>


I have already set the "Google Base Link" and "Domain name" to option with the following format


https://myeshop.gr
  1. 2 weeks ago
  2. RO CSVI
  3. # 4
Accepted Answer Pending Moderation
I wrote the above post and then saw your reply.
1. I was using the file_url and replaced it with the suggested picture_url. Now i get my pictures exported normally
2. I tested the "Refresh SEF urls" from maintenance option but it will always end to a time out. I will try again after raising a bit my server limits.
3. Using just the "Export SEF Urls" to template i managed to have my file exported normally.
4. My first problem is already solved with the provided patch and now i get all the available countries updated.

Thank you very much Tharuna for your time and efford.
I will open a new post in case i have more questions as at the moment you have really helped me a lot. Have a great day :)
  1. 2 weeks ago
  2. RO CSVI
  3. # 5
Accepted Answer Pending Moderation
Hello,
Glad to know that all your issues are solved:)
Kind regards,

Tharuna

=========================
If you use CSVI, please post a rating and a review at the Joomla! Extension Directory
  1. 2 weeks ago
  2. RO CSVI
  3. # 6
  • Page :
  • 1


There are no replies made for this post yet.
Be one of the first to reply to this post!