1. DaPowerrr
  2. RO Payments
  3. Thursday, 30 January 2020
  4.  Subscribe via email
Hi,

I have a problem using rseventspro and ro payments.
I also use the cart plugin (mostly because of the extra fields options)

When I purchase a subsciption to an event now, and pay with ideal (through you) I dont get the succes status in rsevents userboard. Staus remains incomplete.
Status in ROpayments is SUCCESS. Waiting some time and refreshing did not do the trick.

I am well aware it could be a vinkje I missed, but please help me in the richt direction please!

(RSEvents 1.12.12 , RO payments 5.2.0 , Joomla 3.9.15 and a Rabo omnikassa profile)
Accepted Answer Pending Moderation
Hello,

Can you please post the transactionlog? You can find that in the Transactions list in the last column. Click on Show to see the transaction log, we should be able to see there what is going on.
Kind regards,

RolandD

=========================
If you use our extensions, please post a rating and a review at the Joomla! Extension Directory
  1. 4 weeks ago
  2. RO Payments
  3. # 1
Accepted Answer Pending Moderation
[2020-02-04 12:09:33] Gekozen kaart(en):

[2020-02-04 12:09:33] Currency: EUR

[2020-02-04 12:09:33] Set transaction details

[2020-02-04 12:09:34] Send customer to URL: https://betalen.rabobank.nl/omnikassa/nl/payment-brand?token=eyJraWQiOiJFTU8iLCJhbGciOiJFUzI1NiJ9.eyJlbW8iOiJlMDNiNzE5Mi1kMTQ5LTQ0ZGItYjU0Ny04YWRhNjE5ZDQxZGQiLCJjaWQiOiJjMmE5LWQ4MzAiLCJleHAiOjE1ODA4MjcxNzR9.tajCSmmWRRrgdq-iOMUH9gnyEyhwMzSvG0q6aB2W9h7cp10i-qxrtsbZHu7ke3VfEc4FSHDr_cRwcukeDZG4CA

This is one from today.

Customer says to have paid, but status remains incomplete as does the log. Normally when payment is full the log is way longer and gives a status 200 .

Thén they recieve the activation mail.

Does this answer help or do you need more info?

Thank you!
  1. 3 weeks ago
  2. RO Payments
  3. # 2
Accepted Answer Pending Moderation
Hello,

If that is the full log for a payment it can mean 2 things:

  1. RO Payments never received the callback from the Rabobank
  2. The callback has never been send


Since option 2 is highly unlikely, all websites using Rabobank would have a problem, I am thinking it is number 1. It is possible if you use a firewall plugin like RS Firewall or Akeeba Admin Tools you may need to whitelist the cli folder. The callback is trying to reach the URL YOURSITE/cli/notify.php, if this is not possible then nothing is going to happen and you get the log you posted.

Have a look at that and let me know how it goes.
Kind regards,

RolandD

=========================
If you use our extensions, please post a rating and a review at the Joomla! Extension Directory
  1. 3 weeks ago
  2. RO Payments
  3. # 3
Accepted Answer Pending Moderation
Thing is, it works 9 out of 10 times. Akeeba admin tools is not installed and/or activated, same for RS firewall.

Last payments went fine again. Strange the least.

Might it be a problem because all cslls come from one IP maybe?

Thanks again!
  1. 3 weeks ago
  2. RO Payments
  3. # 4
Accepted Answer Pending Moderation
Hello,

Thing is, it works 9 out of 10 times.
From your initial post I understood it always happens not just sometimes. If it happens sometimes, the only place to look is at the server access log. In that log you need to find out when the user was doing the subscription and then check when the Rabobank call came in or when the user came back. In the log it should show if the Rabobank call came in and what status it received. For this you may need the help of your hosting provider.

One thing is certain, the call never made it to the cli/notify.php file. The big question is why and the server access log should give some more insight into this.
Kind regards,

RolandD

=========================
If you use our extensions, please post a rating and a review at the Joomla! Extension Directory
  1. 3 weeks ago
  2. RO Payments
  3. # 5
Accepted Answer Pending Moderation
Sorry I wasn't clear in my initial posting...

I am going to ask my hosting provider for insight as I have no clue where to watch otherwise.
Don't want to mess up things ;)

I just don't get the transactions that get through beautifully and then just a few that don't get a response from Rabo Omnikassa.
All are initiated at same location and even from same IP.

Very big thanks for your help so far, will be back!
  1. 3 weeks ago
  2. RO Payments
  3. # 6
  • Page :
  • 1


There are no replies made for this post yet.
Be one of the first to reply to this post!