1. Dtorr1981
  2. RO CSVI
  3. Wednesday, 21 September 2016
  4.  Subscribe via email
Hi Guys,

I'm having a strange issue with a K2 category import, I haven't used this before, but i'll had some pretty crazy experience with VM imports so I thought this would be easy.

I have a very basic category export from one site, which I am importing into another site, just basic fields no params or anything. The import seems to run through successfully, I cant see anything particular in the debug logs, but the categories just do not appear. Very odd. I have attached my log file and import file. I'll continue playing with this for the time being and awaiting your response.:)

Oh, additionally, the preview shows correctly also.
Best Regards
Donna
Accepted Answer Pending Moderation
Hello Donna,
The issue with your import file is the id field. You should not be having this field as CSVI will only do a update if this field is found. No new inserts would happen. You should remove this field so CSVI uses alias or category_path field for doing a insert or update of records. Try it and let me know.
Kind regards,

Tharuna

=========================
If you use CSVI, please post a rating and a review at the Joomla! Extension Directory
  1. more than a month ago
  2. RO CSVI
  3. # 1
Accepted Answer Pending Moderation
Hi Tharuna,

Oh I see, let me try. I was concerned without the ID field that when I import the params they wont match up as some of my categories inherit parameters from others? I'm just creating the Item export/import now and immediately notice there isn't a category field in this export either. How do the items, categories and params all link together?

Regards
Donna
  1. more than a month ago
  2. RO CSVI
  3. # 2
Accepted Answer Pending Moderation
As an update, I removed the ID and re-imported but only the last category 'growth-hacking' is being imported. The others are being updated but still not showing. I'm struggling to get into phpmyadmin at the minute and i cant seem to find the maintenace option to remove k2 data like there is for VM, so I guess i'm stuck at the minute. I'll have to post back once I can get into the database.

Regards
Donna
  1. more than a month ago
  2. RO CSVI
  3. # 3
Accepted Answer Pending Moderation
Hello Donna,

You should have the category_path field available in the category import. Settings are applied only to the last category in the category_path as that is the category you are working on. If you want to set settings for categories higher up you will need to specify them individually. So a category path like Clothes/pants/men would only touch the men category. To do the pants category you will need it as well but with a category path as Clothes/pants.

The parent field is not needed either in this case as CSVI will take that from the category_path.

some of my categories inherit parameters from others?
The inheritFrom field requires a category_path that it inherits from and CSVI will set the correct ID for you.

I'm just creating the Item export/import now and immediately notice there isn't a category field in this export either.
The item import must have the category_path field available as well. If you don't see it, please see the Missing fields in CSVI article.

i cant seem to find the maintenace option to remove k2 data like there is for VM
There is no such option indeed. However if you import the data CSVI will update it with the data in your file and things should be correct.
  1. more than a month ago
  2. RO CSVI
  3. # 4
Accepted Answer Pending Moderation
Hi Rolannd,

I have updated the tasks and available fields (i had previously updated the available fields as I was aware of this), the issues i am experiencing are:

1 - When exporting the categories, the params field is not contained i.e. it over runs in the remaining columns and pushes everything to the right. Without this field i can import the categories ok.

2 - When exporting items, the export is incorrectly formatted, it wont even complete the preview stage or analyze in the component.

Sorry to be a pain guys. The export file and log file is attached.

edit: The export file seems to be too big (even when zipped).

Best Regards
Donna
Attachments (1)
  1. more than a month ago
  2. RO CSVI
  3. # 5
Accepted Answer Pending Moderation
Hello Donna,
1 - When exporting the categories, the params field is not contained i.e. it over runs in the remaining columns and pushes everything to the right. Without this field i can import the categories ok.

params field holds JSON format values and so it is exported so, if you are looking at only adding inheritFrom value to category, you can directly add inheritFrom field to your export fields instead of params field, while import CSVI will add this inheritFrom value to params automatically else if you need the whole of params field, try opening file in an text editor, that should help.

2 - When exporting items, the export is incorrectly formatted, it wont even complete the preview stage or analyze in the component.

The cause is that category ids 32,35 and 37 are running in an infinite loop. Probably these are assigned to be parent category to each other and so loop is not ending. There is something wrong with the structure of these categories which you need to check.
Kind regards,

Tharuna

=========================
If you use CSVI, please post a rating and a review at the Joomla! Extension Directory
  1. more than a month ago
  2. RO CSVI
  3. # 6
Accepted Answer Pending Moderation
Thank you, I can manually sort out the params as I only have 8 category's so i'll skip that for now.

With regards to the other issue, I have just checked those category and none of them have assigned parent category's? These categories have over 500 articles between them and have never caused a problem, apart from trying to export through CSVI? What sort of problem are you suggesting I fix? I'm clueless.

Regards
Donna
  1. more than a month ago
  2. RO CSVI
  3. # 7
Accepted Answer Pending Moderation
Hello Donna,
Can you send me the access to your database to check this category issue or you can even send me your K2 category table mysql dump to check?
Kind regards,

Tharuna

=========================
If you use CSVI, please post a rating and a review at the Joomla! Extension Directory
  1. more than a month ago
  2. RO CSVI
  3. # 8
Accepted Answer Pending Moderation
Hello Donna,
Did not hear from you back on PM message, is your issue solved?
Kind regards,

Tharuna

=========================
If you use CSVI, please post a rating and a review at the Joomla! Extension Directory
  1. more than a month ago
  2. RO CSVI
  3. # 9
  • Page :
  • 1


There are no replies made for this post yet.
Be one of the first to reply to this post!