1. tilio
  2. RO CSVI
  3. Saturday, 02 November 2013
  4.  Subscribe via email
Hi,

I think I need some help to start.

I've just bought the last version (5.13) of CSVI pro to import users from a CSV File.
I cant do anything. I don't have any user import menu . At first I thought I need to use the process menu but it needs templates I don't have.

I try to find any help in the documentation but there is none for joomla 3.0 and none to halp me with my import problem.

In fact I need just some help to figure how this program works.

Thanks for your help.
Emmanuel
Accepted Answer Pending Moderation
Hello Emmanuel,

At first I thought I need to use the process menu but it needs templates I don't have.
You need to create the template yourself since CSVI has no clue what file you are import or what you want to do :)

I don't have any user import menu .
It is on the process page where you select Import -> Joomla users -> User import.

In fact I need just some help to figure how this program works.
The principle is as follows: You create a template in which you specify what you want CSVI to do. In your case Joomla Users import. The template contains further settings to tweak your import. The most important of all is the fields, you need to map the fields of your import file to the fields in CSVI.

To import Joomla users, you can follow the Manage Joomla users tutorial.

Once the template is setup, you can load your file and run the import.

Let me know if you have any further questions.
  1. more than a month ago
  2. RO CSVI
  3. # 1
Accepted Answer Pending Moderation
Thank you for your answer.

I've try to use the post you refer to create a template but I do not have an option Menu.
And yet I realize I don't have the User import either.

I've taken a screen capture so you can see if it's the right interface or not.

Thank's for your help.

Emmanuel
Attachments (1)
  1. more than a month ago
  2. RO CSVI
  3. # 2
Accepted Answer Pending Moderation
Hello Emmanuel,

It looks like you didn't complete the 2nd step of the installation. On the page you have shown me, there is in the menu the last option called Installation. Click on that and complete the steps there. You should have the options available now.
  1. more than a month ago
  2. RO CSVI
  3. # 3
Accepted Answer Pending Moderation
Thank you !

It seems to work, I'm going to make some test tomorrow.
I hope it will work despite the error I had during the installation.

I come back to you as soon as I've all tested.

Emmanuel
Attachments (2)
  1. more than a month ago
  2. RO CSVI
  3. # 4
Accepted Answer Pending Moderation
Hello Emmanuel,

The error can be ignored since it is for VirtueMart and you don't use VirtueMart. I am going to try again to reproduce this but for some reason it seems elusive when I try :)
  1. more than a month ago
  2. RO CSVI
  3. # 5
Accepted Answer Pending Moderation
Hi,

I've try to import but I can't get there.

First I still have the installation menu and still no Option menu as it is specify in the tutorial.
In addition, I have a new error when I try to start an import. You will see the error on the picture.

Thanks for your help ;-)

Regards,
Emmanuel
Attachments (1)
  1. more than a month ago
  2. RO CSVI
  3. # 6
Accepted Answer Pending Moderation
Hello Emmanuel,

First I still have the installation menu and still no Option menu as it is specify in the tutorial.
I see it in the screenshot, it says Joomla Users.

The other error you see is because you have set error reporting too high. CSVI does not follow the PHP strict standards. So you will have to lower your error reporting in the global configuration of Joomla. After that is done, CSVI can operate normally.
  1. more than a month ago
  2. RO CSVI
  3. # 7
Accepted Answer Pending Moderation
Hi,

I don't have any error anymore but I don't have the field I need to import users.
I had a look on the tutorial page but In the Template I can only add th following :

1 fullname fullname userimport
2 password_crypt password_crypt userimport
3 skip skip userimport
4 usergroup_name usergroup_name userimport

Do you have any idea ? I think I might do something wrong, but I don't know what ...
Thanks for your help.

Emmanuel
  1. more than a month ago
  2. RO CSVI
  3. # 8
Accepted Answer Pending Moderation
Hello Emmanuel,

Do I understand it correct that you only have 4 fields you can add? If that is the case, try updating the available fields. You can click the top panel and select Available Fields, on this page click on the Update button. This will add all the available fields again. There may have gone something wrong with that before due to the error reporting.
  1. more than a month ago
  2. RO CSVI
  3. # 9
Accepted Answer Pending Moderation
Hi Rolandd,

This is exactly the problem. I don't have all the field I need.

When I try to update in the Available Field I get the error :

Une erreur s'est produite

0 SQL=/* Custom fields */ INSERT IGNORE INTO `htwk5xt3o2jos_csvi_available_fields` (csvi_name, component_name, component_table, component) (SELECT TRIM(custom_title), TRIM(custom_title), 'productimport', 'com_virtuemart' FROM `htwk5xt3o2jos_virtuemart_customs` WHERE field_type IN ('S', 'I', 'B', 'D', 'T', 'M', 'Y') );

I do my best, but each time I try something I get an other error ;-)

Regards,
Emmanuel
  1. more than a month ago
  2. RO CSVI
  3. # 10
Accepted Answer Pending Moderation
Hello Emmanuel,

This error I believe happens because of some old data. Is this a migrated site? Is there ever in the history of this site been an installation of VirtueMart? CSVI checks the extension table for installed extensions, if there is a trace of VirtueMart left, this will explain the error you see.

The solution for now is quite simple, go to the folder administrator\components\com_csvi\install\availablefields\ and delete the file com_virtuemart.sql. After that you can run the update available fields again and it should finish.
  1. more than a month ago
  2. RO CSVI
  3. # 11
Accepted Answer Pending Moderation
Hi Roland,

Now I got an other error :

Une erreur s'est produite

0 SQL=INSERT IGNORE INTO `htwk5xt3o2jos_csvi_available_fields` (csvi_name, component_name, component_table, component) (SELECT TRIM(name), TRIM(name), 'itemimport', 'com_k2' FROM `htwk5xt3o2jos_k2_extra_fields` );

We never installed any VirtueMart version. It's a standard 1and1 server installation.

Regards,
Emmanuel
  1. more than a month ago
  2. RO CSVI
  3. # 12
Accepted Answer Pending Moderation
Hello Emmanuel,

This is a clean Joomla 3 website? In any case, except deleting the VirtueMart file, you can delete all files related to components you do not use from the same folder as before.

I just want to understand why your installation is telling CSVI that these components are installed. Would it be possible to send me Joomla and FTP login details so I can check? You can email them or private message them to me. Deleting the files now will work but if you update later, the problem will return, that I don't want.
  1. more than a month ago
  2. RO CSVI
  3. # 13
Accepted Answer Pending Moderation
Hello Emmanuel,

Thank you for the access details. I have identified the problem. The reason CSVI got triggered to install VirtueMart and K2 related fields is because it found these XMap plugins and thought that the components were installed. This is now fixed and you can update the available fields whenever you want.
  1. more than a month ago
  2. RO CSVI
  3. # 14
Accepted Answer Pending Moderation
Thank you, it seems to work, but now I can't access the tutorial to manage joomla users. The link you sent me is not working anymore. Is there a new link ?

Thank you,
Emmanuel
  1. more than a month ago
  2. RO CSVI
  3. # 15
Accepted Answer Pending Moderation
I Found Out !

Thank you very much for your help !!

Regards,
Emmanuel
  1. more than a month ago
  2. RO CSVI
  3. # 16
Accepted Answer Pending Moderation
Glad to hear all worked out :) Thank you too.
  1. more than a month ago
  2. RO CSVI
  3. # 17
  • Page :
  • 1


There are no replies made for this post yet.
Be one of the first to reply to this post!